WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Network Menu Missing WordPress "Own Directory" (7 posts)

  1. cottagemagpie
    Member
    Posted 1 year ago #

    Hi there,

    I just set-up Network on my existing install of WordPress (3.5.1), and the menu for the Network Admin is pointing to "mydomain.com/wp-admin/network" instead of where I need it to, which is "mydomain.com/wordpress/wp-admin/network" -- and I haven't been able to figure out how to fix it. Any suggestions?

    I followed the instructions in Create a Network, and I had my wordpress files in the subdirectory /wordpress/ prior to adding the multisite information to my wp-config.

    The relevant bit of my wp-config is currently:

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'cottagemagpie.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    And my .htaccess at the root is:

    RewriteEngine on
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Any ideas? I tried just manually typing in the network address so I could gets started, but all of the links internally in that section are also missing the "/wordpress/" so none of them will work for me.

    Thanks in advance!!

    ~Angela~

  2. Interestingly enough... they ALL work for me on my site (I just did a nested WP in it's own directory Multisite to test this).

    But I think I know why. Here's my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) wordpress/$1 [L]
    RewriteRule ^(.*\.php)$ wordpress/$1 [L]
    RewriteRule . index.php [L]

    See how there are two lines near the end with wordpress/$1 and YOURS have just $2 ? I think that's what's going on.

    Put in foldername/$1 instead (my folder name is wordpress in this case)

  3. cottagemagpie
    Member
    Posted 1 year ago #

    Thanks -- so I tried just subbing out the $2 for the wordpress/$1 (my wordpress install is in /wordpress/ also), and that just gave me 404 errors. So I decided to just try your .htaccess wholesale, and that worked... kinda.

    So I can use the Network Admin screens just fine. The URL's are still wrong (weird), but they work -- I can add sites, etc..

    BUT, when I try to visit the Dashboard for the subsides, they give me a redirecting error. My main site still works, it goes to /wordpress/wp-admin/ as usual. But all the network sites are not working.

    For example, I have a network site in /gardening/ and the URL that shows in the browser is /gardening/wp-admin/ - and Firefox tells me: "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    More ideas??

    I really appreciate your help. I haven't written a RE since the early '90s.

    ~Angela~

  4. cottagemagpie
    Member
    Posted 1 year ago #

    FYI, I don't know if this matters, but I am working from a WP that was upgraded to 3.5.1, but I upgraded *before* activating the Multisite option.

    (I forced the subdirectory option, I know there are no posts with names that will conflict -- I double-checked before I did it).

    I would be willing to start from a completely fresh install except that I have several hundred posts and thousands of comments and I'm a little concerned about how to do that effectively. Setting up on a different domain and then moving seemed daunting, and exporting everything, rebuilding and reimporting seemed a little nailbiting also....

    ~A

  5. So I can use the Network Admin screens just fine. The URL's are still wrong (weird), but they work -- I can add sites, etc..

    That's supposed to happen (yeah, I know).

    But your 404/redirect loop is becuase you're using the wrong .htaccess ;)

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) wordpress/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ wordpress/$2 [L]
    RewriteRule . index.php [L]

    I didn't realize you were on subfolders, so I gave you subDOMAIN :)

  6. cottagemagpie
    Member
    Posted 1 year ago #

    OH, thankyouthankyouthankyou! It worked! Woo hoo!

    ~Angela~

  7. addy75
    Member
    Posted 1 year ago #

    Hi all. I researched the web and this forum until I found this post and it's such a breath of fresh air to find my exact issue. I share the same issue as cottage - the Network Admin is pointing to "mydomain.com/wp-admin/network" instead of where I need it to, which is "mydomain.com/public/wp-admin/network (where my subdir is "public" and not "wordpress" )

    I used the code above but to no avail. I am new to this forum and I want to follow proper etiquette so I just wanted to ask, is it ok to share my problem here or do I create a new post? Just checking. Anyway any help anyone can assist me with will be greatly appreciated. I am the end of my rope. Here is my code so far:

    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'mydomain.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) public/$1 [L]
    RewriteRule ^(.*\.php)$ public/$1 [L]
    RewriteRule . index.php [L]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.