WordPress.org

Ready to get started?Download WordPress

Forums

Network instalation troubles (3 posts)

  1. pvtpyro
    Member
    Posted 3 years ago #

    Trying to install the network part of wordpress. Once I add the following lines everything breaks down:

    define('WP_ALLOW_MULTISITE', true);
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/network/';
    define( 'DOMAIN_CURRENT_SITE', 'www.private.org' );
    define( 'PATH_CURRENT_SITE', '/network/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    I went to the debugging page and I checked everything. I have full permissions on my host and my database. It tries to repair errors but I get this message:

    wp_1_posts: Table 'holygadg_wrd2.wp_1_posts' doesn't exist
    wp_1_comments: Table 'holygadg_wrd2.wp_1_comments' doesn't exist
    wp_1_links: Table 'holygadg_wrd2.wp_1_links' doesn't exist
    wp_1_options: Table 'holygadg_wrd2.wp_1_options' doesn't exist
    wp_1_postmeta: Table 'holygadg_wrd2.wp_1_postmeta' doesn't exist
    wp_1_terms: Table 'holygadg_wrd2.wp_1_terms' doesn't exist
    wp_1_term_taxonomy: Table 'holygadg_wrd2.wp_1_term_taxonomy' doesn't exist
    wp_1_term_relationships: Table 'holygadg_wrd2.wp_1_term_relationships' doesn't exist
    wp_1_commentmeta: Table 'holygadg_wrd2.wp_1_commentmeta' doesn't exist

  2. pvtpyro
    Member
    Posted 3 years ago #

    I read somewhere it was a simple scripts problem. So I did a fresh install on my own and have the exact same errors

  3. shirazdrum
    Member
    Posted 3 years ago #

    Drop all the tables for:

    blogs
    blog_versions
    site
    sitemeta

    on your database. get the wp-config.php and your htaccess file back to original. If your site has an older installation of WP, upgrade first and then add this line to your theme's function.php. It will force the wordpress to accept sub-directories rather than sub-domains.

    add_filter( 'allow_subdirectory_install',
    create_function( '', 'return true;' )
    );

    Now try to install the MU feature. hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic