WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Network blog only working if we don't forget the final / (5 posts)

  1. Sabinou
    Member
    Posted 2 years ago #

    Hello,

    On my new dedi, I noticed a relatively annoying hindrance.

    For the domain paumadou.com, there is a network blog called ulysse, present in paumadou.com/ulysse/

    However, from my experience and on top of all from my blogs browsing, if a first time visitor only opens paumadou.com/ulysse (without the final slash /), the visitor is redirected to paumadou.com

    I can assume this matches my log entries with
    [error] [client 93.182.135.114] File does not exist: /home/paumadou/public_html/ulysse

    However, on the second attempt, loading either /ulysse or /ulysse/ works.
    And if the first time visitor starts with /ulysse/ then it's OK, the network blog will load.

    I may have left something behind, I was running short of "never been there before" web browsers to do the testing ;)

    Please, would you have an idea as to the reason behind it ?
    And, more importantly, about how to avoid it ?

    (tech info : I simply copied the files and database of that domain from the shared hosting where everything was working perfectly, to the new dedi in which everything equally works perfectly, save this trailing slash bug I just discovered. No funky homemade htaccess of sorts, it's the default stuff.)

    Thank you very much if you can help ! :)

  2. Trying paumadou.com/ulysse and that does send me to http://www.paumadou.com/ (note the www).

    Trying http://www.paumadou.com/ulysse send me to http://www.paumadou.com/ulysse/ (with the / at the end).

    I think that's what supposed to happen. This is a multisite via sub-directories, your root or primary blog is http://www.paumadou.com with the www not paumadou.com.

    When you arrive there with the wrong name, it sends you to the primary blog. When you use the correct name without the trailing slash, you are sent to the correct URL with the / at the end.

  3. Sabinou
    Member
    Posted 2 years ago #

    Actually, I never even notice when I type an url with or without the "www" part, but in my examples above, I had cut it to simplify things.

    However, you may very well be making a point, that could be the cause of the problem.
    Thank you for your reply, Jan !

    And - sorry to come back with a different question ! - could the error I saw in my server logs be, in fact, linked to people opening the domain without the www, just like I did ?
    Because there WAS this error, after all...

  4. could the error I saw in my server logs be, in fact, linked to people opening the domain without the www, just like I did ?

    That's possible and easy to check. Add a ?test-to-find to the end of your URL and check both your access log and error_log. Putting the ?test-to-find will give you a simple string to search for in the log.

    The addition of that parameter will not do anything but finding that in your log will be much simpler. If you see that, then it's you. :) You'll see something similar for my requests just now.

    The access_log should have a 301 response for the same URL and time stamp. You can match that time with your error_log. If they match then that's it.

  5. Sabinou
    Member
    Posted 2 years ago #

    NOW, that's something very useful, on a WIDE scale !

    Thank you very much for the tip, Jan !

    I'll make this thread "resolved" for the moment, hopefully my wife's blog will keep on working well.
    Thanks for the support :)

Topic Closed

This topic has been closed to new replies.

About this Topic