WordPress.org

Ready to get started?Download WordPress

Forums

Network admin GONE!! (10 posts)

  1. Pradino
    Member
    Posted 11 months ago #

    Hi,

    I've been working using a temp url (http://lnxwebr02.cpt.wa.co.za/~lchurch) given by my hosting service. Everything was working fine and I was ready to start using the website using its normal url:life-church.co.za. From there, I asked the hosting service to make the change, which they did; they edited the url link in the database and wp-config.

    I actually don't understand what happened but the Network admin in my dashboard is now gone and I cannot see or accessed my child websites.

    When in the wp-config I change the line define('MULTISITE', false); to define('MULTISITE', true); I receive the message "Error establishing a database connection". On the main site, when I click on one of the link taking me to a child site, it says "NOT Found".

    This is my WP-CONFIG file:

    /*define('WP_ALLOW_MULTISITE', true);*/
    define('MULTISITE', false);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'life-church.co.za');
    define('PATH_CURRENT_SITE', '/');
    /*define('DOMAIN_CURRENT_SITE', 'lnxwebr02.cpt.wa.co.za');
    define('PATH_CURRENT_SITE', '/~lchurch/');*/
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Can anyone help please?

  2. Well...

    define('MULTISITE', false);

    That's kinda a big clue.

  3. Pradino
    Member
    Posted 11 months ago #

    The reason I have define define('MULTISITE', false); is because define('MULTISITE', true); gives me the following error message:
    Error establishing a database connection

  4. Paul Barthmaier
    Contributor Day Volunteer
    Posted 11 months ago #

    Not a problem! I have alerted the authorities and we are hot on the tail for your network admin!

    Here's the thing, it was sure swell that your hosting company help you take care of your database, but it's likely that they didn't get everything that you needed. If you can ask them to search and replace your database, you'll be in fine shape. You'll need to replace your temporary URL with your normal one, but it's a little more complicated than that.

    The reason your site works when you have Multisite off and not when it's turned on is that the main site, the only real site with a folder and stuff, will have the URL at the root of your installation. When not multisite, all you needed to do was change the site URL and home in the WordPress settings or the options table in the database. It doesn't even care what you have specified in your wp-config as your domain's current site.

    But when Multisite is involved, it's going to look for a set of tables in your database that a single site installation doesn't care about or know about. The first stop along the way is your wp_site table which is likely where you are running into trouble. If it still has your temporary URL as its home, you are going to get the error establishing a connection. Why? You are typing life-church.co.za in your browser, the server looks in wp-config and finds that it's a multisite and checks the site table only to find lnxwebr02.cpt.wa.co.za and it thinks it has the wrong multisite. And even if you change that one, it will go on to the wp-blogs table and look at what you have there. Again, if it's not identical, it will throw the error sign.

    Think you can get this from here?

  5. Pradino
    Member
    Posted 11 months ago #

    Thank you @Pali, I'm busy looking into the different tables hoping to get it right.

    P.S: I also asked the US government if with their PRISM programme, they would have an idea of what happened :-)

  6. Pradino
    Member
    Posted 11 months ago #

    I went through all the tables in my database starting by wp_site where I changed from the temp to the normal url. I then went back to my wp-config file and changing define('MULTISITE') from false to true brings back the error to establish connection... I do not know where else to look or do :(

  7. You're also missing this:

    define('MULTISITE', true);
  8. Pradino
    Member
    Posted 11 months ago #

    When I set define('MULTISITE', true); I get the Error establishing a database connection.

  9. Let me rephrase.

    You have TWO things wrong.

    This

    /*define('WP_ALLOW_MULTISITE', true);*/
    define('MULTISITE', false);

    Should be this

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);

    Are BOTH done?

  10. Pradino
    Member
    Posted 11 months ago #

    Yes;

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'life-church.co.za');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    BUT then I got this:

    Error establishing a database connection

Reply

You must log in to post.

About this Topic

Tags

No tags yet.