WordPress.org

Ready to get started?Download WordPress

Forums

Nested Blockquotes - WordPress should correct invalidly nested XHTML ... (1 post)

  1. jokeofalltrades
    Member
    Posted 7 years ago #

    I just tried to nest two blockquote elements (because I was quoting someone who quoted someone else along the way), but I had the option selected to "correct invalidly nested XHTML", and it broke my nesting scheme. The problem is that blockquote elements may be validly nested under the XHTML 1.0 and 1.1 DTDs, so that WordPress wasn't correcting anything that needed correcting.

    Of course, I'm not the first to discover this problem - it was reported as a bug almost two years ago, and reposted as a thread in the support forum last year. But the bug is marked as "closed defect: worksforme", and I'm not smart enough to tell if that means it will be fixed in the next version, or if someone thought they had already fixed it. I'm using 2.1.3, the current stable release.

    Is it fixed? Or should I submit another bug report? Or is there a way to reopen the old bug report?

    Also, while I'm thinking about it - Markdown doesn't single quotes beginning sentences or at the start of decade abbreviations right. The quote mark at the beginning of the number in something like <i>That '70s Show</i> should be an apostrophe, not an opening (left) single quote.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 7 years ago by jokeofalltrades
  • This topic is not resolved
  • WordPress version: 2.1.3