WordPress.org

Ready to get started?Download WordPress

Forums

Need WordPress header to sit above SMF forum (7 posts)

  1. snieves23
    Member
    Posted 4 years ago #

    Hello everyone,
    I am having the most unpleasant time trying to figure out how to get the wordpress header to sit above my smf forum.

    WordPress is root, smf is sub. I have looked online for about a week now, treacherously with no luck!

    SMF and wordpress have been out for a long time, and I have seen dozens of sites that have accomplished this (emailed them too!) but with no response.

    I mean... there has got to be someone here who is willing to share?! :D

    Its the only thing from making my site live. I came from a full blown joomla site which is easy to integrate such things with a click of a button.

  2. snieves23
    Member
    Posted 4 years ago #

    What do I have to do to get help? Can I pay someone? lol c'mon now! :D

  3. WP Voyager
    Member
    Posted 4 years ago #

    Try looking at this Codex Article: http://codex.wordpress.org/Integrating_WordPress_with_Your_Website

    It seems that calling your WordPress header would require a require statement (or comparable). Check out the Article for details.

    Also, search the forum with a query similar to this: http://wordpress.org/search/integrate+website?documentation=1&forums=1 There are so many people that want to integrate WordPress into existing static or dynamic websites. There has got to be some helpful information somewhere!

  4. snieves23
    Member
    Posted 4 years ago #

    Tried it all, not sure where to place the codes on the SMF part. I have asked on SMF, and they are telling me to ask here..lol

  5. snieves23
    Member
    Posted 4 years ago #

    I managed to find where I have to place the code.

    It goes right under the body tags in index.template

    I am getting an odd error, as if it can't locate the file.

    I am getting something like this:
    I put the code right under the body tag and I got this error:

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib64/php:/usr/lib/php') in /home23/site/public_html/dog-forum/Sources/Load.php(1742) : eval()'d code on line 181

    I have this right under the <body> tag
    /* Wp header */
    define('WP_USE_THEMES', false);
    require('./wp-blog-header.php');

    WordPress is in my root, smf is in a sub.

    Any ideas?

  6. snieves23
    Member
    Posted 4 years ago #

    Ok,
    I got the header to show up finally on the forum site.com/forum, but thats all thats showing.

    Its calling my header but not displaying the forum under it? Any ideas?

    Here is the code I am using.

    /* Short and sweet */
    define('WP_USE_THEMES', false);
    require('"my server path"/wp-blog-header.php');

    define('WP_USE_THEMES', false); get_header();

    I found the folders in smf I am suppose to put these into, thing is the rest of the smf forum isn't loading???? Any ideas?

  7. lgice
    Member
    Posted 3 years ago #

    Any Update on this I really cant find any help with this??????

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.