WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] NEED URGENT HELP IMMEDIATELY (17 posts)

  1. archard
    Member
    Posted 7 years ago #

    Something catastrophic has happened to my site. http://www.gametabs.net

    I've had my permalink structure set to /%postname%/ for a very long time. Tonight, I decided to mess around in CPanel, and I turned hotlink protection on. I'm not sure exactly what this did, but it appears that it totally destroyed my permalink structure. I go to my site and the homepage and forums work fine, but whenever I try to access a normal page on the site I get a 404 error. I check the Permalink Options in the WordPress control panel and the permalink is set back to default. No big deal I though, I'll just set it back to /%postname%/.

    Well that did not work, and it appears that when I turned hotlink protection on, it rewrote my .htaccess file, which now says just this for the WordPress section:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    </IfModule>

    # END WordPress

    I am hoping that I can just add in the redirect info that used to be inbetween the # BEGIN and # END and everything will be fine and dandy, but I do not know what is suppposed to go there.

    Someone help me please, this site is my livelihood and generates a lot of income for me as well. I really need this to be fixed ASAP.

  2. citeewurkor
    Member
    Posted 7 years ago #

    sometimes when I run into permalink issues, I update it twice to get it to kick into gear.

  3. archard
    Member
    Posted 7 years ago #

    I've already updated it at least 20 times. Sorry forgot to say that.

  4. citeewurkor
    Member
    Posted 7 years ago #

    That's ok, archard. Do you have a backup of your .htaccess file? Might be able to use that?

  5. archard
    Member
    Posted 7 years ago #

    No, thats the problem. I dont' know what to put in there. I was wondering if someone with the same permalink structure could tell me what is in their .htaccess file?

  6. citeewurkor
    Member
    Posted 7 years ago #

    ok, i think this is the default if you have wp in your root folder:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    not 100% sure though. htaccess isn't my usual cup of tea....

  7. citeewurkor
    Member
    Posted 7 years ago #

    archard, I left some curly braces out, did you try the above?
    my bad..

  8. archard
    Member
    Posted 7 years ago #

    no, not yet, go ahead

  9. citeewurkor
    Member
    Posted 7 years ago #

    I edited it just now.

  10. citeewurkor
    Member
    Posted 7 years ago #

    It appears to be working again?

  11. archard
    Member
    Posted 7 years ago #

    Oh wow, it worked! :D:D:D:D:D:D:D:D

    Man, I don't know how to thank you enough. The amount of time and stress you just saved me... I am so relieved. The world needs more good people like you.

  12. citeewurkor
    Member
    Posted 7 years ago #

    yay! You're very welcome. These forums have saved me more than once. :)
    Happy game tabbing!

  13. helveto
    Member
    Posted 7 years ago #

    @archard

    Do you know that using capitals in the internet is like yelling. Writing in CAPITALS is known as shouting, and some people find this offensive (it is also harder to read).

    Additionally, you don't have to yell for a so easy to fix problem:
    http://wordpress.org/search/permalink+htaccess+rules?documentation=1&forums=1&blogs=1

    You do not have to ask for an immediate help, either...

    ;-)

  14. citeewurkor
    Member
    Posted 7 years ago #

    ok, Mr. member since January 14, 2007 with one post. This is your first post here, and it is to belittle somebody who thought they killed their blog?
    sheesh..

  15. moshu
    Member
    Posted 7 years ago #

    still... every word is valid in that "single post"...
    (just for the record)

  16. helveto
    Member
    Posted 7 years ago #

    Oh! I forgive...

    And there is no suggestive words about the subject of this feed in his title.

    ;-)

  17. archard
    Member
    Posted 7 years ago #

    Sorry helveto... I was in a panicked state when I made the topic, because like citeewurkor said, I thought I killed my site. The point was to get attention to the topic rather than to offend people. And yes, I did search through the wordpress documentation as well as many other external sites before I posted here.

Topic Closed

This topic has been closed to new replies.

About this Topic