WordPress.org

Ready to get started?Download WordPress

Forums

Need to Reset Password Each time (7 posts)

  1. niccol
    Member
    Posted 4 years ago #

    I recently installed wordpress. All is fine except that I need to reset the admin password each time.

    The password works fine each time for that browser session. On a new browser session the password will not work. I do not get the 'wrong password' message. Rather I am just returned to the login screen.

    Doesn't appear to be a browser specific issue as I have tried firefox chrome and opera.

    I am running wordpress 3.0.1 and have no additional mods running whatsoever.

    Any help would be greatly appreciated

    Thanks

  2. Try decativating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Default theme (WordPress 2.9) or the Twenty Ten theme (WordPress 3.0) to rule-out a theme-specific issue (it's probably not theme-specific, but you might as well check anyway).

  3. I almost want to say it's a hash or salt key issue. Check in you wp-config and make sure that no keys, nonces or salts are duplicated. Then clear out your browser cache.

  4. niccol
    Member
    Posted 4 years ago #

    Pretty sure its not a issue with plugins as there aren't any.

    Definitely not a theme issue either.

    I don't reckon it is a salt issue, although that makes sense. I have tried several versions of the keys. And do not have any repeated keys in the config.

    Also I have tried '' as all the keys so I can look at what is being put into the database. I am right in thinking that that results in straight MD5?

    I thought it might be an htaccess thing with other things on the site. WordPress is in it's own directory. But disabling all other htaccess doesn't cure the issue and the wordpress folder isn't being operated on by any of the other htacess anyway.

    I am going to install again in a new directory and see how that goes.

    Any ideas would be gratefully accepted at this point :-)

    Nick

  5. Stab in the dark here...

    In your wp-config, remove all non alphanumeric characters for your keys, nonces and salts.

    ONCE I've seen this work.

  6. niccol
    Member
    Posted 4 years ago #

    I tried all kinds of alpha-numeric keys. No joy.

    However, a clean install in a different directory works fine. Strange. Still it is a fix so that is good.

  7. Try generating a new set of keys from the generator linked to in the wp-config.php file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.