WordPress.org

Ready to get started?Download WordPress

Forums

Widgets on Pages
[resolved] Need to make the link to wop.css relative, not absolute (3 posts)

  1. AsraiLight
    Member
    Posted 1 year ago #

    I am implementing SSL on our website, and redirecting users to HTTPS on certain pages. Unfortunately IE displays a rather ugly error that not all of the content on the page is being delivered over HTTPS, so it's not fully secure. The link to the widgets on pages stylesheet, which is embedded in the header, is part of this content.

    How can I edit the location of the stylesheet so it's relative, not absolute, and bypass any mention of http:// or https://?

    http://wordpress.org/extend/plugins/widgets-on-pages/

  2. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    Hey there,

    The wop.css is linked to with the following line in the widgets_on_pages.php at line ~284

    function add_wop_css_to_head()
    {
    	echo "<link rel='stylesheet' id='wop-css'  href='".get_settings('siteurl')."/wp-content/plugins/widgets-on-pages/wop.css' type='text/css' media='all' />";
    }

    If you alter this you should be able to make the link relative.

    Oh, you could also uncheck the option to use the Widgets on Pages CSS and implement you're own CSS.

  3. AsraiLight
    Member
    Posted 1 year ago #

    Thank you, I changed line 285 to this:

    echo "<link rel='stylesheet' id='wop-css' href='/wp-content/plugins/widgets-on-pages/wop.css' type='text/css' media='all' />";

    And it worked perfectly. Is this something that can be changed in an upcoming version? I know that I'll have to make this change again when I update the plugin, when and if there is an update.

    Perhaps using my own CSS is the best way to go, though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic