WordPress.org

Ready to get started?Download WordPress

Forums

Need to clear cache to see updates (7 posts)

  1. jfilan
    Member
    Posted 6 years ago #

    Every time I update or a someone comments I cannot see the changes until I clear my cache. Is there a setting I need to enable in order for this to stop? I want to be able to see the changes/posts/pages/comments/widgets right away.

    I have installed other WordPress for other people and also for myself and never had this problem until this latest version.

    Is anyone experiencing this? If so, how have you solved it?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    What cache do you have to clear? Your browser? Wp-Cache? WP-Super-cache? You need to be more specific.

  3. jfilan
    Member
    Posted 6 years ago #

    I'm constantly clearing my browser cache in order to see updates/comments/css changes. I have to do this for all browsers. At first I thought it was IE7 only but it's FF, IE5+, Safari, etc.

  4. minute44
    Member
    Posted 6 years ago #

    etag issue?

  5. jfilan
    Member
    Posted 6 years ago #

    I commented out

    //@header("ETag: $wp_etag");

    on wp-includes/classes per this article

    http://lapcatsoftware.com/blog/2006/12/17/wordpress-bug-friday-wasting-your-bandwidth/

    but I'm still experiencing the same behavior. I thought it might be the theme I am using so I switched back to default and also classic but still the same.

  6. jfilan
    Member
    Posted 6 years ago #

    Please leave a comment on the site to see what I mean:

    http://www.iamklaus.com/

    On index.php, please note the number of comments on the post before commenting. For example, the latest post has 2 comments. When you try to add a third it works fine on the actually post/entry page but when you go back to index.php it still says 2. Then you can refresh the crap out of the page and nothing happens. You will have to clear your cache to see it change to three.

  7. jfilan
    Member
    Posted 6 years ago #

    if I add a "?" to the end of the URL string then I see the updates. for example: http://www.iamklaus.com/?

    like I have to make a dynamic call to the server to see each update.

    I tried switching the permalink structure back to the default (?p=22) but still the same behavior.

    What do you think?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags