WordPress.org

Ready to get started?Download WordPress

Forums

Need Some Plugin Testers- WYSIWYG Plugin (40 posts)

  1. Norgs
    Member
    Posted 9 years ago #

    mosco:
    I'm having a problem troubleshooting the image paths thing since I can't reproduce it and no one else has reported having the same problem :-(.
    Try this:
    1.Open up Wysi-Wordpress/wordpress.js
    2.Find the line:
    theme_advanced_toolbar_align : "left",
    3.Just below that line, add this:
    relative_urls : false,
    4. Test out the editor to see if paths are fixed. If not, try adding this after the relative_urls line:
    remove_script_host : false,
    5. Test again.
    Be sure to open a new browser to test each time so that the javascript is reloaded, and you don't get the unchanged cached version.

    Joe,
    Thanks for this...
    I was running this wonderfull plugin on a site with the blog at the root of the page, and was finding that the images would upload and look fine in the edit window, but when published, they had a different path.
    The images were supposed to be at 'http://www.site.com/wp-content/uploads' , but onced published I was seeing 'http://www.site.com/index.php/wp-content/uploads' .
    The fix listed above solved the problem. (on a windows hosting solution too)

    Thanks again Joe.

  2. moikirsch
    Member
    Posted 9 years ago #

    Hi!

    Let me give you a few ideas that I implemented on my plugin (the other wysiwyg plugin).

    You could use for uploading the default upload folder for wordpress (wich the user can change in the wp options).

    I'm going to download your plugin later and see what else can be done.

    If I don't like it I'll have to make my own version to compete with yours :)

  3. radial
    Member
    Posted 9 years ago #

    on line 45 on config.php i had to make my line include a '/'at the beginning even though your instructions in config.php said not to. otherwise, pictures links were missing the slash.

    // WYSI-WORDPRESS- Change the line below to the location of your images
    // directory FROM your main URL. For example, if your main URL is
    // at http://mysite.com/ and your image directory is at
    // http://mysite.com/blog/images , this setting would be blog/images/
    'value' => '/blog/images/',
    'text' => 'Site Pictures',

  4. Ron Pemberton
    Member
    Posted 9 years ago #

    I'm getting an error message for line 98 in the edit-form-advanced.php. any fix for this? Also, nothing has been appearing at all. anywhere. Not in the plugin listing under options.Not in the Write or Edit areas, not even when advanced edit is clicked.

  5. polopo43
    Member
    Posted 9 years ago #

    It is great but how do you add a link to a file (I mean no image/picture kind of file, say .doc for instance) thanks.

  6. Heatsink
    Member
    Posted 9 years ago #

    I love this thing, but I'm having permission problems.

    If I upload images via FTP then they are set to 644 which works fine. If I upload them with your editor, they are set to 600 which doesn't work. They show in the list, but the server won't let me look at them. (forbidden).

    This is probably s linux problem rather than an editor problem, but I thought I would see if anyone can point me in the right direction here.

    Thanks

  7. Joe
    Member
    Posted 9 years ago #

    Heatsink:
    Get the new version of the plugin. It will automatically chmod the files for you so that they are readable.

  8. dthomasmaddox
    Member
    Posted 9 years ago #

    Joe,

    I can't get the plug-in to install. I tried transferring the folder/files just as they were unzipped. The plug-in manager can't see them. I tried several other variations, no luck.

    Can you please tell me which files and folders have to be in the /wp-content/plugins folder? I feel like I'm missing something really straightforward.

    Also, do I understand that this plug-in won't work in Firefox?

    Thanks,

    Tom

  9. dthomasmaddox
    Member
    Posted 9 years ago #


  10. gzenone
    Member
    Posted 9 years ago #

    is there a way to use the <!--more--> with WYSIWYG Plugin

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.