WordPress.org

Ready to get started?Download WordPress

Forums

Need site to go live (9 posts)

  1. ozzieguy
    Member
    Posted 1 month ago #

    Hello Guru's

    I have a site [www.mydomain.com.au]that also has a multisite and I need both to go live.
    I am lost as to how to do it

    Obviously my 1hr 30 mins searching has got me frustrated :-)

    Help please.

  2. I don't have any idea what you mean by "go live" - how are they not live right now?

  3. ozzieguy
    Member
    Posted 1 month ago #

    Thank you Mika, lol, the site cannot be seen as yet, everything is still in the WP sub Directory.
    I need to be able it to be seen by everyone.

    I hope that makes sense.

  4. Marc
    Member
    Posted 1 month ago #

    You have a normal install of WordPress, and a multisite install of WordPress installed on your webhost? If they are installed on your webhost, then they are already live. Unless you have a maintenance mode plugin installed, anyone can already access it. Also, a link to your site would help us better understand your problem.

  5. ozzieguy
    Member
    Posted 1 month ago #

    Thank you Marc.

    I had to copy the index.php file from the WP Folder to the Root Directory and do an edit in it ie: Change the line that says:
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );
    to the following, using your directory name for the WordPress core files:
    require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' );

    I have done just that yet when I type in the www address it does not load and only will load the site when I place the Directory that has the WP Install.

    http://www.dartsaustralia.com.au gives nothing and loads this:
    http://dartsaustralia.com.au/dartsauwp/

    Many thanks guys, if I can get this part to work I may be a happy little vegemite again :-)

  6. Marc
    Member
    Posted 1 month ago #

    When I visited http://dartsaustralia.com.au/, I got an "Error establishing a database connection" error. But, http://dartsaustralia.com.au/dartsauwp/ loads ok.

    How to fix Error establishing a database connection: http://www.youtube.com/watch?v=-xu1zWxNBh0

    Also, have you tried reinstalling WordPress via the updates page.
    Screenshot: http://www.mediafire.com/view/fp5446r8sae5k78/Reinstall_WordPress_from_update_page.JPG

  7. ozzieguy
    Member
    Posted 1 month ago #

    Thank you Marc, I will try that, or it looks like I may have to start all over again :-(

    I thought that I was getting the DB error because of how I have set up the multisite.

    I appreciate you at least trying to help me Marc, much appreciated.

  8. Marc
    Member
    Posted 1 month ago #

    Alright. Tell me how it goes.

  9. Just FYI, you cannot (easily) do that with Multisite.

    Are you really running multisite in a subfolder and trying to move it to look like it's running out of the root folder like v ia this? https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

Reply

You must log in to post.

About this Topic

Tags

No tags yet.