WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Need MFunc (5 posts)

  1. Vajaah
    Member
    Posted 1 year ago #

    Custom functionality has been created around mfunc and the option referenced in the Advanced Settings page to enable dynamic content is greyed out. The condition referenced in the plugin's code to cause the setting to be inaccessible don't seem applicable. How can we be sure that the mfunc tag for dynamic content can function while running 1.3.2.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    You have to set caching to PHP mode, I forgot to add that to the settings page. :(

    Unfortunately mfunc is going to disappear in the next release, to be replaced by something much better and safer, a filter using your own tags. It's not backwards compatible and works in a completely different way.

    Check out the post and my comment here for more info. You should *definitely* download the development version or svn export from trunk (link in the comment) and try it on a test server. There's an example plugin with documentation describing what it does. Any feedback would be really appreciated.

  3. Vajaah
    Member
    Posted 1 year ago #

    We are currently using legacy mode, could this still work? We understand that this will be removed, but anytime we can buy to develop another means to achieve the custom functionality based on it will help.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Remove this from line 983 of wp-cache.php:

    <?php if ( $wp_cache_mod_rewrite || $super_cache_enabled == false ) { echo "disabled='disabled'"; } ?>

    The checkbox should no longer be disabled.

  5. Vajaah
    Member
    Posted 1 year ago #

    Thanks! That's the line we found. We didn't want to edit the plugin files if we didn't have to.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic