WordPress.org

Ready to get started?Download WordPress

Forums

Need instructions to remove TinyMCE from WP (8 posts)

  1. Ciryaquen
    Member
    Posted 8 years ago #

    Please.... I need specific instructions in newbie language for permanently removing TinyMCE from my WordPress blog.

    I have already tried 1. all the hacks for making it behave and 2. turning it off. It continues to mess up my code.

    See my previous post
    http://wordpress.org/support/topic/73161?replies=14

    Please, I am desperate to get rid of TinyMCE. Please tell me how do I get rid of it. It's simply the most horrid user-unfriendly thing I have ever encountered in WordPress.

  2. Samuel B
    moderator
    Posted 8 years ago #

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    No hacks are needed.

    Options->Writing-> Disable "Users should use the visual rich editor by default"

    Users->Bottom of the screen -> Disable "Use the visual rich editor when writing"

    Done. It's disabled. Really.

  4. Ciryaquen
    Member
    Posted 8 years ago #

    Thanks for the replies. But I still need an answer.

    Samboll,

    I'm sorry that thread you linked went over my head higher than a jet.

    Otto42,

    In theory your method works. In theory.

    In reality, it does not work.

    As I alread posted in my other thread in response to how did I try to disable TinyMCE

    a) In Users > Your Profile> Personal Options deselecting "Use the visual rich editor when writing"
    b) In Options > Writing deselecting all 3 choices under Formatting "Users should use the visual rich editor by default", "Convert emoticons like :-) and :-P to graphics on display", "WordPress should correct invalidly nested XHTML automatically"

    It didn't work on 3 installations: 2 Linux shared hosting sites, and my local OS X copy.
    http://wordpress.org/support/topic/73161#post-384671

    Please I still need specific newbie language for how to delete/remove all traces of TinyMCE and still have an otherwise functional copy of WordPress.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    What do you mean by "didn't work", exactly? Because that method does work. I used it myself. So have most people on these forums. There's really nothing more to it.

    You can't "delete/remove all traces" of it without major hacking of WordPress. But just turning it off has the exact same effect.

    Really, all you have to do is what you labelled as step A. The other option just changes the default setting of that for new users. And you don't have to turn off the "correct invalid HTML" and the smilies thing, those are not related to TinyMCE.

  6. Nazgul
    Member
    Posted 8 years ago #

    Otto42: As I've stated in his other thread, I don't think TinyMCE is the culprit in this case, but the wpautop filter is.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    Oh. Well, if *that's* the problem, just add remove_filter('the_content','wpautop'); to your theme's functions.php file. No more wpautop, and it'll survive an upgrade.

  8. Ciryaquen
    Member
    Posted 8 years ago #

    Thanks for the help. As far as I could tell from searching the forum and Codex the TinyMCE was "fixing" line breaks. Noone until Nazgul ever mentioned the wpautop.php.

    Really there needs to be a better way to let people use line breaks if they choose.

    The problem is that I'm trying to set up a site for someone. They don't know html so letting them use the rich text editor and this wautop cleaning up their code is OK under normal circumstances. I just need to be able to layout the pages I need to using line breaks.

Topic Closed

This topic has been closed to new replies.

About this Topic