WordPress.org

Ready to get started?Download WordPress

Forums

Need IIS advice on allowing php to update local files (5 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    I've got a client who we've built a WordPress site for on Linux and ported it to their windows server environment. Their "webmaster" doesn't know how to configure their server. I can write to mysql just fine, but when it comes to doing straight forward theme updates that should edit php code directly on the server it appears that the permissions to write through the web interface are not there. Adding to the issue is that we have a separate admin tool that is writing to mysql, but when generating xml from php scripts nothing is writing to the local /xml directory.

    Is there a setting in IIS or php that permits writing to local directories?

  2. Xamataca
    Member
    Posted 6 years ago #

  3. x11tech
    Member
    Posted 5 years ago #

    I'm currently in a similar situation. The webserver that I've installed my WordPress installation on is IIS6, Windows 2003.

    Currently, the WordPress installation works fine except when I wish to modify files using the web interface (i.e., Design > Theme Editor, or Plugins > Edit)

    I receive a "File Updated Successfully" after submitting the changes, but what loads in the window is the unmodified file.

    In the end, I have to make all of the changes in a text editor and upload them. While this does work, I'm hoping to simplify things by figuring out what setting has been introduced in to the system configuration to cause this problem.

    My question (having read the "Changing_File_Permissions" and "htaccess_for_subdirectories" links pasted above) is what user account in IIS is used to perform the local file modification?

  4. levous
    Member
    Posted 5 years ago #

    Open IIS Admin. Right click on your website. Select "Directory Security" tab. Click on the "Edit" button in the "Authentication and Access Control" section. Copy the user you see there. Usually "IUSR_MACHINENAME"

    Give that user write permission in the wp_content directory

    Hope that helps

  5. zeb_macahan
    Member
    Posted 5 years ago #

    One very simple clarification:

    Where do you grant the write permission to the wp-content folder: running XP with II's (5.1) so I have tried the Explorer's access attributes without success...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags