WordPress.org

Ready to get started?Download WordPress

Forums

Need help with images uploading after moving wp (6 posts)

  1. yodibashi
    Member
    Posted 5 years ago #

    Hello, after I moved my domain from a subdomain to the root, I have this error message when I try to upload an image.
    Can anybody help me out?
    I checked the wp-content folder for write access it has CHMOD 777 so that should not be the problem?

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/stanto01/:/tmp:/usr/local/lib/php/)

    Unable to create directory /wp-content/uploads/2009/05. Is its parent directory writable by the server?

  2. WebmistressM
    Member
    Posted 5 years ago #

    Was this a migration from a localhost copy?

    If so, your path might be incorrect. Go to Settings>Miscellaneous and check the path and make sure it matched. For example, my localhost copy goes to /var/www/_subfolder_ It still retained those settings in migration of course so I had to remove /var/www/_subfolder_ altogether.

  3. yodibashi
    Member
    Posted 5 years ago #

    Hello Webmistress, thank you for your answer..
    Not a migration, localhost copy.

    My settings-Miscellaneous, say:

    /wp-content/uploads

    That's maybe right? Don't know..the full path is:

    domains/domainname/public_html/wp-content/uploads/
    I checked this path through my ftp client.

  4. yodibashi
    Member
    Posted 5 years ago #

    Hello webmistress,

    I tried something..
    Found a solution, just deleted everything in the box where you give the upload directory. Now it works again.

  5. atcrawford
    Member
    Posted 5 years ago #

    yodibashi, thanks so much for posting your reply about how you got it working! I was pulling my hair out trying to get this working. Then I tried what you said you did (deleting everything in the box), and it works like a charm now!

    Thanks so much!

  6. Chris Brennan
    Member
    Posted 4 years ago #

    This fix worked for me as well. Just in case anyone needs clarification on what steps to take, you go to the settings menu in the dashboard, then click miscellaneous. In the miscellaneous settings menu erase any text in the first two fields titled "Store uploads in this folder" and
    "Full URL path to files". Blanking out those fields seems to solve the problem.

    Thanks a lot yodibashi!

Topic Closed

This topic has been closed to new replies.

About this Topic