WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Need help with changing table prefix and .htaccess (4 posts)

  1. gordon7
    Member
    Posted 4 years ago #

    Hello everyone

    I just setup my first WP site. And it appears that everything is working as it should.

    However, I just installed and activated the WP-Security scan which tells me "The file .htaccess does not exist in wp-admin/ and Your table prefix should not be wp_. Click here to change it."

    I installed WP in the root directory of the site. I located the .htaccess file, and it is indeed outside of the wp-admin folder. I opened up the file and this is what it says:

    # BEGIN WordPress
    
    # END WordPress

    Do I just move the .htaccess into the wp-admin folder? And if I do have to move the file, do I leave the .htaccess outside the wp-admin alone or do I delete it?

    With that said lets move on to changing the table prefix.

    When I try to to rename them I get the following error message:

    Your User which is used to access your WordPress Tables/Database, hasn't enough rights( is missing ALTER-right) to alter your Tablestructure. Please visit the plugin documentation for more information. If you believe you have alter rights, please contact the plugin author for assistance.

    I checked and I do indeed have ALTER-right.

    I then proceeded to the plugin documentation: http://semperfiwebdesign.com/documentation/wp-security-scan/change-wordpress-database-table-name-prefix/

    I followed all the instructions and when I finished I get this error message:

    There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.

    I am completely lost now, so I do hope that someone can help me.

    Thanks in advance,
    Gordon

  2. gordon7
    Member
    Posted 4 years ago #

    The .htaccess file now contains the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Under permalink settings > custom structure I had /%postname% instead of /%postname%/

    Hopefully the rest of the problems are just as easy to fix.

  3. gordon7
    Member
    Posted 4 years ago #

    All is fixed.

  4. d4jaj1
    Member
    Posted 4 years ago #

    Thanks, I was looking for that

Topic Closed

This topic has been closed to new replies.

About this Topic