WordPress.org

Ready to get started?Download WordPress

Forums

Need help to remove Askapache plugin (19 posts)

  1. xiaozhu
    Member
    Posted 6 years ago #

    Hi,

    I really need some help to remove the Askapache password protect plugin, since I installed it, I can't access my blog at all anymore (either through the url, either using wp-login.php).

    The plugins says:

    If you experience an error that you can't fix by disabling a security SID from the AskApache Password Protection Option Panel or resetting/re-activating the plugin, all you need to do is remove the sections added by the plugin from the 2 .htaccess files using ftp, ssh, webftp, or contact support, etc..

    Problem is, of course, I don't know which lines to delete.

    Any help would be much appreciated.

  2. whooami
    Member
    Posted 6 years ago #

    if you installed it, you edited the file, right?

    so you would delete whatever you added.

  3. xiaozhu
    Member
    Posted 6 years ago #

    I wish.

    The plugin modified the files for me, I didn't do anything but activate the plugin and choose a username and password.

    It was my mistake to install this plugin but now I'd love to fix that. I can't find any clue on how to remove the plugin properly!

  4. whooami
    Member
    Posted 6 years ago #

    ok, well paste whats in your .htaccess right now, and ill tell you what to delete :)

  5. xiaozhu
    Member
    Posted 6 years ago #

    Thank you very much for your help!

    Here what I have:

    .htpasswda1

    /home/correres/public_html/.htpasswda1

    # BEGIN AskApache PassPro
    admin:{SHA}m1FLpo+kMEpuKq8AikZ5cYneAKg=
    # END AskApache PassPro

    Root .htaccess

    /home/correres/public_html/.htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Not sure if I'm supposed to post the first one (password) but at this stage, I don't care, I just want my blog back!

  6. whooami
    Member
    Posted 6 years ago #

    this looks like a like candidate doesnt it? realize that you need to deactivate the plugin, and delete the plugin file(s).

    # BEGIN AskApache PassPro
    admin:{SHA}m1FLpo+kMEpuKq8AikZ5cYneAKg=
    # END AskApache PassPro

    As that file contains ONLY that, you may, can, and should delete the entire file. Dont even bother editing it.

  7. xiaozhu
    Member
    Posted 6 years ago #

    The only problem is, if I try to desactivate the plugin, I get the following error:

    The requested URL returned error: 500

    Otherwise, I have just deleted the file you mentioned (not the plugin!), but still no luck in accessing my blog.

    This one is a true mystery to me, I've been trying to delete the thing for a day now!

  8. whooami
    Member
    Posted 6 years ago #

    then you use your ftp client, and you delete the files that make up the plugin. Or have you already done that?

    And you need to delete that file. askapache uses .htpasswd to restrict access. Its not complicated to get rid of that stuff.

  9. xiaozhu
    Member
    Posted 6 years ago #

    Sorry for being a bit dumb (I'm not blond, just tired!). ;-)

    I did try to use FTP to get rid of the plugin. Still wouldn't have access to my blog.

    Let me try one more time to delete both the plugin folder + the htpasswd..

  10. xiaozhu
    Member
    Posted 6 years ago #

    Nope, still no access.

  11. whooami
    Member
    Posted 6 years ago #

    if you contact me via the contact form on my site I will help you. I would need ftp access.

  12. xiaozhu
    Member
    Posted 6 years ago #

    I just sent you an email using the contact form.

  13. Roy
    Member
    Posted 6 years ago #

    AskApache makes an htaccess in each folder you want to protect, so most likely, there's also one in the admin folder. Edit out the AskApache bits in the htaccess in the root AND the admin folder and then delete the plugin files.

  14. whooami
    Member
    Posted 6 years ago #

    thats already been done.

  15. Roy
    Member
    Posted 6 years ago #

    Just an addition for future users with the same question :-)

    xiaozhu, you can mark this thread as resolved.

  16. whooami
    Member
    Posted 6 years ago #

    it's not resolved, she says still cant access the blog.

  17. xiaozhu
    Member
    Posted 6 years ago #

    Sorry everybody for the late reply, I was away ysterday.

    Thank you Whooami, you've been very helpful the other day.

    However, I still can't access my blog. It seems the plugin is totally removed but the problem remains.

    This is the deal:

    People can see my blog just fine. I was able to login in the dashboard as usual from a friend's computer.

    If I try to access my blog from home, I don't get any error page, the blog just doesn't load. Either the url, the login, the pages... can't see anything.

    Same from my husband computer at home, so it's not a security software blocking me.

    I can access my blog through a proxy and login, but some functions seem limited. However, this is probably due to the proxy. For example, if I try to upgrade a plugin, I get this error: The requested URL returned error: 500. It could be part of my problem though, I don't know.
    My internet connection is fine, I don't have problem with any other websites.

    This led me to believe my server is blocking my IP. But how, why and how to undo that?

  18. ccpetersen
    Member
    Posted 5 years ago #

    Hello,

    i've run into the same problem. Running wordpress 2.6.0, and was fiddling around with settings in Askapache password protect. I managed to do something wrong and it kept asking me for passwords to do anything. I put in the password, still not working. (I'm using Mozilla Firefox 3.0, and also tried this with IE, get the same prlblem on both).

    In PP it asked me to verify my password, so I did.

    Now I can't get in to my dashboard to edit my blog. I do get the dashboard screen, but as soon as I try to log in, a little box pops up that asks me for name and password.I put that in, it won't let me in; eventually I get a screen that says:

    Authorization Required
    This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.41 Server at XXXXXXXXX Port 80

    So, I went in and deleted the PP plugin, deleted the .htaccess in wp-admin, took out the PP info in the main (root) .htadmin, and deleted the .htapassword3 file.

    I am still being asked for the password, and I've trashed my cache in both browsers. What am I missing?

    thanks.

  19. ccpetersen
    Member
    Posted 5 years ago #

    Aha! I found one more .htaccess file to delete...

    please ignore above...

    thx.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags