WordPress.org

Ready to get started?Download WordPress

Forums

Need help managing comments (5 posts)

  1. ecmoran
    Member
    Posted 7 years ago #

    Hi, I'll just say upfront that I'm far from savvy at html, css and anything else code-related. I designed my blog in psd and had a someone help me produce it in wordpress.

    As the only admin of the blog, I'm coming across what appears to be glitches with incoming comments. Rather than showing up in the front page and counting as a comment, certain comments ending up under the art itself and there is no reference on the front page that a comment exists. Here's an example: http://www.cabcabinmoran.com/blog/?attachment_id=16

    Is there a way to control the hierarchy of comments? Can I move the comments so that they show up from the main page? I hope the solution is simple b/c I am basically a blog user not developer.

    Hope someone can help! Thanks, in advance...
    ~Edna

  2. rudolf45
    Member
    Posted 7 years ago #

    Hmmm... The answer, probably, is no.
    Every comment is related to a WP entry: be it post, Page or - in your case - attachment.
    The most usual thing is when comments are made on posts; in this case on your main (index) site their number is shown.
    (On normal blogs comments are not made on Pages, so let's skip that.)

    Since WP 2.x when uploading an image there is the option to link for example the thumbnail size image to
    a) the original size
    b) to a "file".
    Well, that file is the "attachment" - in your link above.
    Since those comments are made not on the post but on the attachment - they show up accordingly: there.
    Which means WP does exactly what was designed for, even if you expect otherwise.

    What you can do:
    - don't link the updated picture to a file: the visitors will be 'forced' to comment on the post!
    - remove the call for the comments template in the attachment.php file

  3. ecmoran
    Member
    Posted 7 years ago #

    Thanks for your feedback. Can you explain how to: (1) Undo the link to the image and/or (2) get rid of the call for comments template in the attachment.php file (which is prob the most permanent solution)? Thanks for helping a clueless user like me!

  4. rudolf45
    Member
    Posted 7 years ago #

    1. When uploading and image and clicking on it, you have several options:
    Not linked
    Linked to original
    Linked to file
    Select "Not linked". You'll never see the attachment file.

    2. That involves editing the attachment.php file - if there is any in the theme. I suspect there is... because it looks like a Deafult clone.
    This is the line that calls the comments:
    <?php comments_template(); ?>
    Change it to:
    <?php //comments_template(); ?>

    If there is no attachment.php file - then stick to the not linking method!

  5. ecmoran
    Member
    Posted 7 years ago #

    Okay, I "fixed" my comments issue using BOTH suggestions, Rudolf45. Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.