WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Need Help getting my blog to appear on sub "/" Directory (9 posts)

  1. Verious B. Smith III
    Member
    Posted 4 years ago #

    Hello everyone I am in need of some help in getting my blog to appear as if it were on a sub directory. I have tried several things after going through the documentation and finally decided on using this article (following it very closely):

    http://codex.wordpress.org/Making_Your_Blog_Appear_in_a_Non-Root_Folder

    I have developed the site on my personal server and it worked well for a while but after I uploaded it to my server it no longer works.

    It also no longer works on my personal server but I cant figure out what went wrong and why it does not work.

    Can any body help???

  2. S.K
    Member
    Posted 4 years ago #

    Let us state clearly as to what exactly is your requirement.

    You want your blog to appear as if it is in a sub-directory of your main domain. EG: http://yourdomain.com/blog/ - but the WordPress files are in your root directory only.

    In this process, there are 2 alternatives:

    1. Your blog will appear in "/blog/" but the posts and pages will have the URL as if they are from the root only. Viz: http://yourdomain.com/2009/07/your-blog-post/.

    If you are satisfied with this scenerio, there are very easy steps:

    a) Create 2 pages - Home and Blog - both set to default template. Write whatever you want to appear on your front page, in the page named "Home". Write nothing in the page named "Blog". Publish.both pages.

    b) In "settings -> Reading", select Front page displays => A static page (select below) option, and select FrontPage => Home and Post Page => Blog.

    You are done.

    2. But if you want your blog posts to have URLs like "http://yourdomain/blog/2009/07/your-blog-post/", then you can follow the instructions contained in the Codex page cited by you earlier in this thread.

    But one step is omitted in the Codex page. That is item (b) above. You have to do that too.

    I tested it. It is working.

    HTH. Give a holler if stuck.

    S.K

  3. Verious B. Smith III
    Member
    Posted 4 years ago #

    Kichu

    Thank you so much for the quick response. I have gone back and adjusted my blog accordingly but what happens now is that my blog shows up on the front page. I am still unable to identify why the template for the front page is not showing up.

  4. S.K
    Member
    Posted 4 years ago #

    Tell us your blog address.

    S.K

  5. Shane G
    Member
    Posted 4 years ago #

    Hi,

    As you have uploaded the blog from local to server which may change the site URL so you need to edit the database and change the site URL also..

    http://codex.wordpress.org/Changing_The_Site_URL

    Thanks,

    Shane G.

  6. S.K
    Member
    Posted 4 years ago #

    My 2 bits - avoid using the "Quickfix" and "Relocate" methods, but carry out the changes in the database as described in the Codex page cited by Shane G.

    S.K

  7. Verious B. Smith III
    Member
    Posted 4 years ago #

    Sorry, my blog adddress is:

    http://www.philoveracity.com

  8. S.K
    Member
    Posted 4 years ago #

    What about the sub-directory you were talking about!

    Can you please list what all you did and what you aimed for.

    S.K

  9. Verious B. Smith III
    Member
    Posted 4 years ago #

    Sorry for allowing this issue to remain open for so long but I finally resolve the problem. Thanks for any and all of your help.

Topic Closed

This topic has been closed to new replies.

About this Topic