WordPress.org

Ready to get started?Download WordPress

Forums

Need Help - Elegant Grunge, Image Header (15 posts)

  1. joshysan
    Member
    Posted 5 years ago #

    Hi everyone,

    I really need some help with my word press theme. I am currently using the lastest version of Elegant-Grunge where I have uploaded a header image via the appearance settings. It worked fine, except my image is displaying in the centre of the page, please see:

    EmotiveDesign Blog/blog

    However, I think it would look much better if it was aligned with the navigation links and body text further left, and I would really appreciate any help you can give me. Please note, I am not very good with CSS so a detailed explanation would be favoured =P.

    Thanks in advance.

  2. michaeltyson
    Member
    Posted 5 years ago #

    You have two options. The simplest is to simply make your custom header image the same width as the Elegant Grunge header, then you can position it however you want. This is the recommended solution. The alternative is to edit Elegant Grunge's header.php, around line 22, the line beginning with background:, and change the center value to something else, like left or right.

  3. wmharris101
    Member
    Posted 5 years ago #

    Michael,

    I absolutely love the theme. I am however having trouble getting my image to show up in the header. I have placed my logo, which is a transparent .png and the location that it exists into the theme per the line that you provided. It brought up a blank header (the gray color remained, but no image). I tried to edit the header.php by reading some information online. Still no luck. Any other ideas.

    The url that I used was images/logo.png

    Thanks,

  4. amol naik
    Member
    Posted 5 years ago #

    Hi wmharris101,

    The problem seems to be your URL. The PHP file does not process images/logo.jpg. Instead provide complete address like
    http://xxxx.com/wp-admin/wp-contents/themes/elegent-grunge/images/logo.jpg

    See if it works!

  5. sgaines62
    Member
    Posted 5 years ago #

    I'm having the same issue with trying to load an image into the header. Actually the strange thing is that it works on my computer but nowhere else. I've entered it as a URL as noted:
    C:\Users\Steve\Desktop\Blog\Pics\Picture1.png

    But on any computer other than my own it is just a gray bar. I'm not a CSS code person, though I'm adept at other computer functions. Is there any suggested fix that I'm just not aware of?

    Love the theme. Just want to be able to insert a logo!

    Thanks.

  6. craigdelk
    Member
    Posted 5 years ago #

    sgaines62, your problem is that you are directing to a file that is on your hard drive. You need to upload the file and point it to a url.

  7. sgaines62
    Member
    Posted 5 years ago #

    craigdelk, that still doesn't work. At least with my webhost (Bluehost). Do you know where I would upload the file? Anytime I do and then copy the url it shows as an "ftp://" url. And that doesn't show up in the header. Nor is it possible to open it as it requires a password. I'm storing it in the public_html directory. But it doesn't seem to work. Thoughts?

  8. sgaines62
    Member
    Posted 5 years ago #

    craigdelk, I even tried to just upload the image into flickr and the link still didn't work. All I get is a gray bar across the header.

  9. brew13
    Member
    Posted 5 years ago #

    sgaines62, Bluehost doesn't have anything to do with your issue and you would not store it in flickr. It seems to be a filename (path) problem. Upload the file to your root directory or a subdirectory on your website using an ftp application like filezilla. Then, be sure to include the full path i.e. http://www.xxx.com/subdirectory/filename.jpg in the appropriate wordpress file.

  10. joeysee
    Member
    Posted 5 years ago #

    Hi -

    I was hoping someone could help me solve a minor problem I'm having with my blog header. I replaced the original header image with my own image, and now, I'd like the blog title to be removed from the header space. I can remove it by simply not titling the blog in the general settings, but then nothing appears in the web page tabs as a title.

    http://www.joeysee.com/blog

    is the address.

    Any thoughts on where to go or what to do to solve this? Any help would be much appreciated.

    Thanks...

  11. bh_WP_fan
    Member
    Posted 5 years ago #

    You could get an SEO plugin. That should allow you to fill in your meta information and should put the title on your tabs, too. You could also edit your header.php file and you should see a line similar to the following:
    <title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
    and fill in between the title tags the title you want to show in your tabs.

  12. Elindil
    Member
    Posted 4 years ago #

    Hi there!
    I have another problem with my site's header image. It seems to be not long enough, but when I try to replace it with longer one, it breaks all header, like this: .
    Normally, with the shorter header image, my site looks like: .
    I want this image as long as the brighter part of site (between these gray lines). Could anyone tell me where I should edit the code and how to change the style to have longer header's image accepted?

  13. Elindil
    Member
    Posted 4 years ago #

  14. Elindil
    Member
    Posted 4 years ago #

    I resolved this problem by simple change type of header's image to .png ^^.

  15. SSpencerblog
    Member
    Posted 4 years ago #

    When I first inserted my header, it was centered. Today, it suddenly shifted left. I've checked line 22. It still says center. Does anyone know how to move my header image back to center?

Topic Closed

This topic has been closed to new replies.

About this Topic