WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Need help: after upgrade to 2.0, I can't access dashboard (5 posts)

  1. changw
    Member
    Posted 8 years ago #

    Hello, I'm testing my WP 2.0 upgrade from 1.5.2 (I guess).
    I followed the steps - backup, deactivate plugins, delete, copy, upgrade.php.
    The "upgrade.php" was done with "actually nothing to do - have fun (step 1)" - is this correct? ( I was expecting some kind of DB operation. )
    Anyway, after upgarde, I can't access to my Dashboard from the 'admin page'. When I click on the "Dashboard" button, I get a blank page and my web server generates the following error log :
    "Allowed memory size of 8388608 bytes exhausted (tried to allocate 0 bytes)"

    Here's the URL.
    and you can see the detail's of the system at this page.

    Thanks.

  2. davidhouse
    Member
    Posted 8 years ago #

    For the first part of your question, yes, something was done and your DB was upgraded. Don't worry about that :) Although I'm not sure about the second...

  3. MichaelH
    Member
    Posted 8 years ago #

    You've hit the php script memory limit. See:
    http://www.tech-recipes.com/php_programming_tips777.html

    So maybe try adding this to htaccess
    php_value memory_limit "16M"

    or contacting host to increase memory in php.ini.

    This may be caused by a large post.

  4. changw
    Member
    Posted 8 years ago #

    Thanks David. Meanwhile, I tested fresh installation using different DB name and got the same result. Now I suspect that it's not a upgrade problem. A s/w version incompatibility (Apache, PHP4), maybe ?
    What's worse, it turned out that I backed up only part of the WP DB tables and I guess there's no downgrading back to 1.5.2 option :-(
    ( I can still post & read. I may have to upload files manually, but I can do that - while waiting for v2.0.1. ) By the way, can anyone show me how to get file/line info. on PHP4 error log?

  5. changw
    Member
    Posted 8 years ago #

    Thanks, Michael, it works! I changed the system's default value to 16M. It's strange though - the log line says I tried to allocate "0" bytes! Maybe the link you gave me will tell me what's been going on, but I can't access the page for some reason. Anyway, thanks again :)

Topic Closed

This topic has been closed to new replies.

About this Topic