WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Navigation not working (6 posts)

  1. Lorraine
    Member
    Posted 10 months ago #

    I had a test server copy running smoothly which has had a fair few issues switching to live at another host. My navigation is not working now, every link defaults to home including network admin. I followed a post which said to type network at the end of the URL so I can now access admin however I cant get the links working. I tried to reset permalinks but that didn't help.

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'xxx.co.uk');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Earlier I did get issues with the wp_site table and domain and path settings but I assume I corrected these.

  2. Lorraine
    Member
    Posted 10 months ago #

    I have removed permalinks altogether and we are working.Does anyone know if this happening in WordPress or if it's a hosting issue.

    I have also noticed that there is an extra / i.e. http://www.xyz.co.uk//wp-admin/options-permalink.php

  3. How did you move WP between the servers?

  4. Lorraine
    Member
    Posted 9 months ago #

    Yes, I did, I think I may have an issues with serialisation. I found that my widgets won't open in the main site but are fine in the sub sites. If I try to update I have issues like the path opening as /wp-admin/blah blah, I then need to manually insert the domain to complete the task. All my admin issues are just on the main site.

    I really want to over write my wp_options manually if it is rather than using a plugin to avoid not knowing what to correct if something goes wrong. I can then just restore the old table. I can't seem to find a list of what data is likely to have serailisation issues.

    I did a search and replace following someones advice when I moved the site and then on more reading realised it was a mistake.

  5. Lorraine
    Member
    Posted 9 months ago #

    Sorry the last post is written very poorly, I guess from more reading I should use a plugin to correct the serialization, are there any recommended ones, or equally ones to avoid.

  6. Lorraine
    Member
    Posted 9 months ago #

    I'm going to close this thread and open a more specific thread as I am aware of what the issue may be.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.