WordPress.org

Ready to get started?Download WordPress

Forums

Navigation Links Not working (20 posts)

  1. thesiegesound
    Member
    Posted 2 years ago #

    I just recently fixed an issue that my website was experiencing with error 500. Once I got everything back up and working again, I noticed that topics I had tagged with certain pages were no longer appearing under their tagged pages. Instead, each page displays a "Leave A Reply query instead. However, all topics still appear in the website body.

    Can anybody help with this issue? Here is my website:

    http://www.thesiegesound.com

  2. dianem326
    Member
    Posted 2 years ago #

    Go to your Pages in the admin. Click on the page that is displaying the "leave a reply", below the area were you insert text you should see Gray bar that says Discussions,click on the gray bar to open up then uncheck both boxes (Allow comments & allow tracks & pings).

    If you do not see the Discussion area, then go to your screen options top right corner, in there check the box discussions, it will make it appear below the text area.

    Hope that works for you, it was how I removed the "Leave a Reply" on my pages.

  3. thesiegesound
    Member
    Posted 2 years ago #

    Dianem326,

    Thanks alot for the help. Unfortunately this did not work for me. I guess I don't really want the "Leave A Reply" query to leave, I just want all of my topics to re-appear under their proper categories.

    For example, when I make a post and categorize it in my "Events" link, I want my topic appear linked to that page. Right now, none of my topics are linking to their corresponding pages, and instead wordpress I'm only getting a "Leave A Reply".

    Again, this issue arose after I noticed my website had an "Error 500- Internal Server Error". Not sure how that would have messed with my page linking. Any other help would be greatly appreciated.

    Here is the website: http://www.thesiegesound.com

  4. dianem326
    Member
    Posted 2 years ago #

    Sorry that didn't help. Did you open each page in the Page admin & uncheck the boxes in the Discussion section? Hmm sorry, that is how I got rid of the "Leave a Reply" on all my pages was unchecking the boxes in the Discussion section below the text area with each of the pages that I created.

    Not sure if any of this might help any of your other problems. Your website has 8 validating errors. You might want to run it through
    http://www.w3.org/QA/Tools/ & check out your errors. I would also run look at look at the css in here too.

  5. thesiegesound
    Member
    Posted 2 years ago #

    Actually Dianem,

    I didn't have a gray box that were were speaking off under the text on my individual pages (about, leaks, music, events, goods). And since you mentioned it, I always remembered there being more information to edit on these indiviudal pages in the admin.

    Instead, I unchecked the "Leave A Reply" stuff by going to the "discussion" tab under the settings on my admin page. Still no dice.

    Funny thing is - the category link (or pages link) that appears above the picture in each of my topic posts, links exactly the way that I need it to link. For example, if you look at the most recent topic "The Siege has Sold Out in Japan" and you click the "Leaks" link directly above it, it will take you to the main leaks page. Now, all I need is for "leaks" link in the "main navigation menu" to target this link.

    I know for sure this is not a css issue. It seems like it's more of a permalinks issue, but all my permalinks seem to be the same as they were when my website was working.

  6. dianem326
    Member
    Posted 2 years ago #

    You need to check the discussion part in you screen options setting at the top of your admin, so that the discussion bar will show up on each page. Then you need to uncheck it there.

    If you uncheck it at the top it doesn't do anything.

  7. dianem326
    Member
    Posted 2 years ago #

    Hope that made sense.If not....

    Top right corner in the screen options make sure the discussion box is CHECKED with the screen option, this will make the gray discussion bar appear under your text area in each page. Then if you uncheck the 2 boxes that start with Allow, your "Leave a Reply" will disappear.

  8. thesiegesound
    Member
    Posted 2 years ago #

    Okay... just edited the discussion under my screen options ( nice little trick for page edits), but that's not solving my navigation links issue.

    http://www.thesiegesound.com

  9. dianem326
    Member
    Posted 2 years ago #

    Both you upper navigation and side bar navigation links take you to a page called Leaks. The only thing on that page is the Leave a Reply, I guess what you are saying is you text is not appearing on this page?

  10. dianem326
    Member
    Posted 2 years ago #

    How did you create your links & pages. When I created my pages it created my navigation links. Then I went in the menu option and organized them.

    Where did you insert your information for these pages, within each page? If not that is where you should do it.

  11. thesiegesound
    Member
    Posted 2 years ago #

    Dianem,

    I understand that very clearly and additionally, I understand the process of building pages very easily. What I am trying to say is that my upper navigation pages no longer display my topic posts that I have categorized under those specific links.

    Just navigate through all of my posts in the the body of my web page. When you look at all of my posts, you will see each post is categorized with the proper link category i.e. about, leaks, music, events, etc.... further, when you click on the category link in any post (about, leaks, music, events) it will take you to a page that is an archive for those specific links (See example in my fifth post). Further, that is what the upper navigation and side navigation link is suppose to do. Instead, it's blank. I dunno why this is happening. Perhaps this is a more complex problem than I originally anticipated.

    http://www.thesiegesound.com

  12. dianem326
    Member
    Posted 2 years ago #

    Ok I see your problem. If you click on leaks below The siege has sold out it takes you to page http://thesiegesound.com/?category_name=leaks

    If you click on leaks in your navigation it takes you to page id http://thesiegesound.com/?page_id=123 two totally different pages, they are not connecting to each other.

  13. thesiegesound
    Member
    Posted 2 years ago #

    Dianem,

    Yes... this is my major problem. Each upper navigation page has a default url - /?category_names=(then insert page) and now those permalinks have change as a result of some update to the website. And for some reason, I can't get the permalinks back to their original url.

    http://www.thesiegesound.com

  14. dianem326
    Member
    Posted 2 years ago #

    When you set up your navigation was it done by you creating the page, did you do it through the menu option or some other method?

  15. thesiegesound
    Member
    Posted 2 years ago #

    Well actually, I remember having an option to create the url in the page editor after the page was created. If gave me an option to create my own url. Then, what that would do is create a category check box on the right has side of the screen where you could then select a category for any topic post... and that would redirect that topic into your main navigation category.

    So basically, each topic post would generate a url extension - /?page_id=(RANDOM NUMBER) and that would get re-directed by checking an appropriate category.

    The main nagivation menu url should NOT have changed. They should have remained with an extension - /?category_name=(INSERT PAGE)

    Now, wordpress won't let me go back and change each page's permalinks back to the original links. And if I go and change it under a custom structure in the permalinks editor, it will display my page with a 404 error.

    http://www.thesiegesound.com

  16. esmi
    Forum Moderator
    Posted 2 years ago #

    I remember having an option to create the url in the page editor after the page was created. If gave me an option to create my own url. Then, what that would do is create a category check box on the right has side of the screen

    That process has never been part of WordPress core.

  17. thesiegesound
    Member
    Posted 2 years ago #

    Esmi,

    Perhaps I was mistaken then. Do you have any suggestions as to how I may alleviate the situation? Here is my website - http://www.thesiegesound.com

  18. dianem326
    Member
    Posted 2 years ago #

    Did you try to delete the pages that are http://thesiegesound.com/?page_id=121, http://thesiegesound.com/?page_id=123 and so on. Maybe then it will let you work with it.

    Not sure if this will work for you but I created a custom links for three of my navigation links at the top. You enter the url that you want the navigation link to go to.

    To do the Custom Links go to the Appearance, Menu, then in Custom Links enter http://thesiegesound.com/?category_name=leaks name it Leaks. Then in the box below that says Pages, you click on each box to add the page to your menu, then off to the right you can rearrange them buy the drag & drop to put the pages order on your navigation.

  19. thesiegesound
    Member
    Posted 2 years ago #

    Dianem,

    Thanks... I will give this a try and report back. Much appreciation for your efforts over these past couple of days :)

  20. dianem326
    Member
    Posted 2 years ago #

    Your welcome. I know what it is like to have issues and you can't figure out what is going on and no one will reply. So I try to help when I can. Hopefully that will solve your problem.

    Best of luck.

Topic Closed

This topic has been closed to new replies.

About this Topic