WordPress.org

Ready to get started?Download WordPress

Forums

Navigation Links missing on Archive pages (5 posts)

  1. laurenbersaglio
    Member
    Posted 1 year ago #

    Hi,

    Recently I noticed the navigation links have vanished from the bottom of the page when browsing by author/category/tag etc.. The links still appear on my homepage in the form of an "Older Entries" button on the botton right of the page. There used to be similar links on all the archive pages.

    I am not sure exactly when the links disappeared, but I do know they were working to begin with.

    My site URL is: http://liberonetwork.com (you will see the "Older entries" link at the bottom of the page)

    and here's the link to an archive page where the navigation links are now missing: http://www.liberonetwork.com/category/anxiety-posts

    Though I understand the basics of CSS and can get my way around, if it is a coding issue I'd appreciate it if you explain it clearly what code I am supposed to adapt/add/remove and what file I will find it under.

    thank you!

  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

    apart from the problem with navigation, your site (example the posted archive link) has various validation errors:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.liberonetwork.com%2Fcategory%2Fanxiety-posts&charset=%28detect+automatically%29&doctype=Inline&group=0

    http://codex.wordpress.org/Validating_a_Website

    general, for the navigation, compare the code of the index template (index.php ?) with the code of the archive.php to see if the navigation code is possibly missing.

    for details, you will need to contact the developer/vendor of your theme for aupport.

    this forum does not support commercial themes; http://codex.wordpress.org/Forum_Welcome#Commercial_Products

  3. laurenbersaglio
    Member
    Posted 1 year ago #

    Thank you for the response.

    I am unsure what you mean by "apart from the problem with navigation, your site (example the posted archive link) has various validation errors." I visited the link but couldn't make sense of what it was saying. Is there a fix for this? What types of problems do these "errors" cause for my site?

    I realize I have a commercial theme; however, the navigation links were there originally and now they have disappeared (and I have not updated/changed my theme) so I can only assume it is a wordpress problem. I have also seen that others have posted about similar issues (though couldn't make sense of the "solutions").

    Any more help/information would be greatly appreciated!

  4. laurenbersaglio
    Member
    Posted 1 year ago #

    "general, for the navigation, compare the code of the index template (index.php ?) with the code of the archive.php to see if the navigation code is possibly missing."

    I am unsure what the navigation code is - if you could give me a sample then I will run a check to see if it appears in both my index and archive.php.

    thanks!

  5. laurenbersaglio
    Member
    Posted 1 year ago #

    I am wondering if anyone is still able to help me with this? I still haven't been able to resolve the problem.
    thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic