WordPress.org

Ready to get started?Download WordPress

Forums

WEBphysiology Portfolio
[resolved] Navigation bar is not displaying (16 posts)

  1. waxsolutions
    Member
    Posted 1 year ago #

    Hi,

    I like your plug-in and used it couple of time, but this time I have a problem with the navigation bar.
    I am using a Elegant theme (Trim) and for some reason when I load the portfolio page the Navigation bar disappear.

    .js #main-menu { display: none }

    when I try to change the CSSS style the nav is broken.

    Anyone can help?

    Thank you

    Johann

    http://wordpress.org/extend/plugins/webphysiology-portfolio/

  2. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Johann,
    What's the URL to the page that is having the issue?

  3. waxsolutions
    Member
    Posted 1 year ago #

    Hi Jeff,

    Thanks for the quick reply.

    the website is not live yet but i will put it live for the next hour for you to have a look.

    http://www.leunginteriors.co.uk/portfolio/

    thanks

  4. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Johann,

    I'm not seeing the portfolio. Is the plugin activated?

    Jeff

  5. waxsolutions
    Member
    Posted 1 year ago #

    oops!
    that was quick...
    try again

  6. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Johann,

    In the portfolio options, try turning off the "Don't register Fancybox jQuery v1.3.4" and see if that makes a difference. If not you might also tick "Don't register jQuery v1.7.1 from Google".

    I noticed a fancybox javascript error. This said, I also see it on other pages, like testimonials. There also are quite a number of JS warnings. Might be worth pinging the theme author about that. Let me know how it goes.

    Cheers,
    Jeff

  7. waxsolutions
    Member
    Posted 1 year ago #

    Thank you very much, I will try that.
    Do you think it might be because I have Lightbox Plus ColorBox install too?

    thanks

    Johann

  8. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    It's possible. You can deactivate all plugins except the portfolio and see if the menus are displaying.

    There may be a contention with the theme, other plugins or even a defect in my plugin but no one else has reported this issue.

    Jeff

  9. waxsolutions
    Member
    Posted 1 year ago #

    I untick all and even switch the Lightbox Plus ColorBox and irrelevant plugins...
    so its a javascript conflict?

    Johann

  10. waxsolutions
    Member
    Posted 1 year ago #

    Thanks for your time.

    I will look deeper.

    Johann

  11. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Difficult to say for certain. When I look at the page source I do see the script from my plugin that calls fancybox code being written before the actual fancybox javascript library is being called. This could cause an error but typically only with fancybox related items.

    If you provide me with a temporary Admin level login and FTP account I can look into this further but it will likely be late my afternoon (California).

    Jeff

  12. waxsolutions
    Member
    Posted 1 year ago #

    that will be cool if you could have a look too.
    email me and I will email you back the loging details.
    johan@seoready.co.uk (my email)
    cheers

    Johann

  13. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Lowered the priority of the code using the fancybox library such that it occurs after the theme has registered the library. Change will be incorporated in v1.4.9.

  14. waxsolutions
    Member
    Posted 1 year ago #

    Jeff,

    Thank you very much for your help.
    Job well done!

    thanks
    Johann

  15. Sewing Geek Pattern
    Member
    Posted 7 months ago #

    I am having the same issue. Is the nav bar supposed to show up automatically? Is there an option to check to make it show up? Is it the tags list?

  16. esmi
    Forum Moderator
    Posted 7 months ago #

    @Sewing Geek Pattern: If you require assistance then, as per the Forum Welcome, please post your own topic. This 7 month old resolved topic references an old version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic