WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
[resolved] navigation arrows (10 posts)

  1. danielle_r
    Member
    Posted 9 months ago #

    Hi all,

    I'm running version 2.6 of this plugin. It all works very well, thanks for the great plugin. But my client wants navigation arrows to move through the pictures < > I've looked on all the tabs at the back end but I can find any settings to activate this. Can this be done?

    Thanks very much in advance for you help, best, danielle.

    http://wordpress.org/plugins/lightbox-plus/

  2. danielle_r
    Member
    Posted 9 months ago #

    Hi all,

    Is there someone who can help me with this? Is there an alternative for the navigation arrows?

    Any help is greatly appreciated. d

  3. sirrieh70
    Member
    Posted 9 months ago #

    Having the same issue, no navigation at all. Checked all the settings, nothing. I rolled back to an older version and they are working fine. We are running the latest version of WordPress with Just one plug in ..This one and the WP default theme.

    Looking at the code, they seems to be hidden. Not sure if that's a bug, but it's really annoying.

    :)

  4. sirrieh70
    Member
    Posted 9 months ago #

    rel="lightbox[1]"

  5. danielle_r
    Member
    Posted 9 months ago #

    Hi sirrieh70,

    Glad to hear I'm not the only one struggling here. What do you mean by your last remark

    rel="lightbox[1]"

    Thanks, d

  6. sirrieh70
    Member
    Posted 9 months ago #

    You need to add this to the code. It all depends of what you are doing. Are you adding the code manually or adding the photos via the editor? Are you using a custom class?

    In my situation I was missing that

    $url = wp_get_attachment_image_src($images, 1, 1);
                    echo '<a href="';
                    echo $url[0];
                    echo '" class="lbp_primary cboxElement" rel="lightbox[1]">';
                    echo wp_get_attachment_image($images,'thumbnail', 1, 1);
                    echo '</a>';
                    }
  7. danielle_r
    Member
    Posted 9 months ago #

    Hi sirrieh70,

    I'm using the child theme accessible-onetwo on the twenty-twelve theme. The code modification above are they in the twenty-twelve theme? If so I'm reluctant to change theme due to theme updates in the future...

    Could you please tell me, where the above code is located, what template it is in? Thank you, d

  8. danielle_r
    Member
    Posted 9 months ago #

    Hi all,

    I've found the problem. The arrows weren't displaying because the css can't find the image. Somehow the link is broken on the "black" style and some other styles. I've solved it by choosing a different style.

    Hope this helps someone, best, d.

  9. muttznutz
    Member
    Posted 9 months ago #

    Hi all,

    I've just implemented LB+CB.

    I had the same problem using the "black/colorbox.css" style .
    The problem seems to be in the section below; the two instances of ".hover" should be substituted with ":hover".

    #cboxPrevious.hover{background-position:bottom left; background:url(images/prevblack.png) top left no-repeat;}
    				#cboxNext{position:absolute; top:50%; right:5px; margin-top:-41px; background-image: url(data:image/gif;base64,AAAA); width:49%; height:100%; text-indent:-9999px;}
    				#cboxNext.hover{background-position:bottom right; background:url(images/nextblack.png) top right no-repeat;}

    Hope this helps,
    Drew

  10. Kipperlenny
    Member
    Posted 6 months ago #

    But this is not solved in the plugin code and for all styles, is it?

Reply

You must log in to post.

About this Plugin

About this Topic