WordPress.org

Ready to get started?Download WordPress

Forums

Tiga
Nav bar not working in mobile layout (18 posts)

  1. lak3000
    Member
    Posted 1 year ago #

    Hi,

    When viewed on an iPhone, the main nav dropdown keeps displaying the last item in the nav, even when you're not on that page.

    And actually, you can't view the last page in the nav--when you select it, it just stays on the page you're currently on.

    Please look at this site on your phone:

    http://www.tompatrickstephens/test

    As you can see, the nav dropdown is stuck on "RESUME" (the last item in the nav), no matter which page you're on. Also, you can't view the "RESUME" page -- when you select it, nothing happens.

    Could you please help?

    Thank you!

  2. Satrya
    Member
    Theme Author

    Posted 1 year ago #

    Hi,
    I can't open the link

  3. lak3000
    Member
    Posted 1 year ago #

    just go to

    http://www.tompatrickstephens.com

    i temporarily solved the problem by adding a blank menu item to the nav bar. so, on your phone, the nav dropdown defaults to blank space.

    is there an easier way to avoid this problem?

    thank you!

  4. Satrya
    Member
    Theme Author

    Posted 1 year ago #

    Please remove the blank menu. I need to see the problem.

  5. lak3000
    Member
    Posted 1 year ago #

    Okay, please look at it now.

    The nav dropdown defaults to "Contact". In addition, you can't view the Contact page.

  6. Satrya
    Member
    Theme Author

    Posted 1 year ago #

    Gotcha, this is the javascript drop-down issue. Please use again the blank menu until I push the update.

    Thanks for the report. By the way, the font on your menu is awesome. :)

  7. lak3000
    Member
    Posted 1 year ago #

    thanks, satrya. looking forward to the update!

  8. lak3000
    Member
    Posted 1 year ago #

    Also -- how do i get an image to display on the home page? I've selected the "Home Page" template and selected a feature image but nothing happens.

  9. Satrya
    Member
    Theme Author

    Posted 1 year ago #

    Just upload an image, it will automatically display on home page.

  10. Satrya
    Member
    Theme Author

    Posted 1 year ago #

    Oh I forgot, if you have any further question. Please post it on my forums http://satrya.me/forums

  11. lak3000
    Member
    Posted 1 year ago #

    I'm clicking on "Set featured image" under "Featured Image", and selecting an image. But the image doesn't appear on the page.

  12. carcar1313
    Member
    Posted 1 year ago #

    Im am having the same problem as @lak3000 with my mobile site menu. I have done the most recent update and it has not fixed this issue. I want the home page link to show up first, not a blank link or the last page.

    Could someone help?

    Thanks!

  13. Andrew
    Forum Moderator
    Posted 1 year ago #

    @carcar1313, You need to upgrade to WordPress 3.5.2 before anything else, otherwise your installation may be compromised.

  14. carcar1313
    Member
    Posted 1 year ago #

    I am using the most current version of wordpress, 3.5.2.

  15. Andrew
    Forum Moderator
    Posted 1 year ago #

    This thread is regarding version 3.5.1.

    You can create your own thread to discuss your own issue.

  16. SPRM
    Member
    Posted 10 months ago #

    Hi satyra,

    I am also experiencing this issue. I just updated to Word Press version 3.6, and updated the theme to a newer version as well. I have the menu order correct on the web, but it's reverse on the iPhone/mobile, where what shows in the navigation is not the same as the Home Page on the screen. Users have commented that they can't get to the page they want and I've instructed them to take a couple of extra steps where they click to another page in the navigation and then back to the original page they had wanted to view.

    I read some threads regarding this and it seems the resolution is for an update to come out? If there are any other ways to fix this problem in the meantime, let me know and I can incorporate them.

    Thanks for your continued help!

  17. Satrya
    Member
    Theme Author

    Posted 10 months ago #

    @SPRM sorry, i already know this is issue couple months ago. But, sorry im still busy with my job and projects. I'll update it soon when i get the time ;)

  18. SPRM
    Member
    Posted 10 months ago #

    Thanks! Your responsiveness has always been appreciated!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic