WordPress.org

Ready to get started?Download WordPress

Forums

Groups
[resolved] Nasty ERROR with latest Version!!! (7 posts)

  1. jasonkadlec
    Member
    Posted 1 year ago #

    Warning: in_array() expects parameter 2 to be array, boolean given in /plugins/groups/lib/core/class-groups-user.php on line 246

    This error shows up all up and down the page...

    This appears to be in some way caused by w3 Total cache...I've disabled cache for logged in users and cleared the site cache and the issue appears to have resolved.

    But worth looking into...

    http://wordpress.org/extend/plugins/groups/

  2. itthinx
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for reporting it Jason, I'll have a look at what's causing it.

  3. itthinx
    Member
    Plugin Author

    Posted 1 year ago #

    I've tried to get this error to happen on a test site with W3 freshly installed and a few hundred users but it doesn't appear. Anyhow, I see when it can happen from the code, so I'll review it and issue an improved version. Thanks again for reporting it :)

  4. jasonkadlec
    Member
    Posted 1 year ago #

    Actually, I ended up getting it to happen again with w3 total cache off -- so I think that was a red herring...

    I switched out back to the older version and looks like that took care of it for now.

  5. itthinx
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed it, if you'd like to try it, it's already in the trunk.

  6. jasonkadlec
    Member
    Posted 1 year ago #

    Awesomeness!

  7. itthinx
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks again Jason, version 1.3.10 is now ready, please give it a try :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic