WordPress.org

Ready to get started?Download WordPress

Forums

Name author changes from admin to other user (7 posts)

  1. katootje
    Member
    Posted 5 years ago #

    Hi,

    I have a few wordpressblogs where I am the administrator and where are more subscribers with roles as author, editor and contributor (if that are the english words, I have the dutch version installed).
    But when I write a post as Admin, the name of the author changes to the first name in the list of other writers. The name Admin is not in the list of authors. This is the problem at at least two different blogs. At the bottom of the editor there is a possibility to change the name of the author - Admin is not on that list. So I have the right to write and publish a post logged in as Admin, no problem, but it will be written in name of one of the other writers. Is this a common problem. Do I have to subscribe twice, once as admin and once as writer to write posts with my own name? I think it is something of 2.7, since I can't remember having this problem before.

    Karin

  2. Hiranthi
    Member
    Posted 5 years ago #

    Hi Karin,

    I'm having the exact same problem (all users are listed in the author dropdown, except for the admin). At first I thought it had to do with the Role manager, but all settings are correct. Everything in the DB is as it should too. So far I haven't been able to solve it yet. But when I do, you'll be the second to know! (As I'd be the first one ;-) ).

    Btw, did you get messages about an update to the core of WP2.7 too (the update-nag)?

    Hiranthi

  3. Hiranthi
    Member
    Posted 5 years ago #

    Well, didn't expect to find it this soon, but I found a workaround for the bug: http://wordpress.org/support/topic/169422?replies=7

    Did have to add a new admin user, login as that one and then change the role to something else, save it and then change it back to administrator (beheerder).

    Hope this helps for you too :)

  4. Hiranthi
    Member
    Posted 5 years ago #

    Okay, just found out that changing the role is a whole lot easier (I should look up the screen a bit more ;-) ).

    Just tick the admin user, then select Administrator (Beheerder) and click the edit/save button (have a Dutch version too, so I'm not 100% sure of what the buttons and all say in the default version).
    The select box is just above the list of users.

  5. ramon fincken
    Member
    Posted 5 years ago #

    Excellent !! Thanks for the update :)

  6. katootje
    Member
    Posted 5 years ago #

    Thanks Hiranthi, I wish I looked earlier here. SO busy I forgot about it.
    I changed the name to another adminuser account I made. This is a lot easier

    Karin

  7. Hiranthi
    Member
    Posted 5 years ago #

    No problem. I forget about this forum (and my posts/topics on it) too.

    Would be nice to get notified when there's an update in a topic you replied in (and ofcourse be able to delete the subscription on a topic).

Topic Closed

This topic has been closed to new replies.

About this Topic