WordPress.org

Ready to get started?Download WordPress

Forums

Mystique Theme - Twitter Problem (14 posts)

  1. arcticchibi
    Member
    Posted 4 years ago #

    The twitter widget for the Mystique theme was working last week, but not it does not work at all.

    It shows tweets like "R" or "/" and it said it was posted 0 seconds ago, but I never posted anything like that. It also does not grab my latest tweets.

  2. mr_stew
    Member
    Posted 4 years ago #

    Same problem, I upgraded the theme to the latest version last night. This is when the problem started. Did you do the same?

  3. digitalnature
    Member
    Posted 4 years ago #

    post more info please, so I can reproduce the bug.
    php version you're site is running, installed plugins, twitter user name...

  4. ByteProject
    Member
    Posted 4 years ago #

    I have exactly the same problem, mentioning this since Mystique 1.4 but sadly the problem did not solve until present day. As workaround I implemented the standard widget from Twitter. Works but it's ugly. Sometimes the Twitter timeline shows up, sometimes not, you will recognize the same on your page.

    http://www.flickr.com/photos/byteproject/4149829178/

    Actually running WP 3.0 Beta 1, Mystique theme 2.2.2 and the following plugins:

    Contact Form 7, Find me on, Lightbox Plus, More Linke modifier, SI Captcha Anti-Spam, Syntax Highlighter Evolved, TinyMCE Advanced, WordPress Beta Tester, WordPress Media Flickr, WPTouch iPhone Theme.

  5. ByteProject
    Member
    Posted 4 years ago #

    Oh, I forgot: deactivating any of those plugins does not affect the bug at all. It is NOT a browser cache issue and my host is running a proper version of PHP5.

    My website is http://www.byteproject.net and my twitter account is: byteproject

  6. brodock
    Member
    Posted 4 years ago #

    Hi, i'm experiencing the same problem right now... and I have a guess about what's happening.

    Since I didn't had enough time, I haven't depurated the code, but I think it's related to your time calculations... (maybe there is a little mistake on the logic to see if there is newer tweets to show or something like that).

    I will update my observations here when I finish the analysis

  7. brodock
    Member
    Posted 4 years ago #

    I found the problem...

    this is what i'm receiving from the json:

    array(2) { ["request"]=> string(25) "/users/show/myuser.json" ["error"]=> string(74) "Rate limit exceeded. Clients may not make more than 150 requests per hour." } array(2) { ["request"]=> string(37) "/statuses/user_timeline/myuser.json" ["error"]=> string(74) "Rate limit exceeded. Clients may not make more than 150 requests per hour." }

    it's look like your code doesn't check "error" from json to see if it's okay or not. Maybe this is a change in API that isn't there when you coded it.

  8. ByteProject
    Member
    Posted 4 years ago #

    I have just published a workaround on my blog, an accceptable and good solution until Milenko (the author of Mystique) fixes said bug.

    http://www.byteproject.net/?p=56

  9. katrinaneufeld
    Member
    Posted 4 years ago #

    I noticed that my Twitter widget stopped working after I installed WP Google Analytics by Aaron D. Campbell. I deleted that plugin and installed Google Analytics for WordPress by Joost de Valk instead. The twitter widget works perfectly now.

  10. digitalnature
    Member
    Posted 4 years ago #

    @brodock and possibly others who are having problems with the twitter widget:

    - your hosts don't allow your wordpress install to retrieve remote data from twitter. search on google "host blocking twitter" for help
    - you have another twitter related plugin/or another website hosted on the same server that is using the twitter API. From the error posted above, I understand the twitter limits requests to 150/hour from an IP. Mystique can reach up to 60 requests per hour (you can change this in widgets.php). On shared hosting, a single IP can host 1000 websites...

    I hope this helps.

    @katrina: paste your google analytics code in the footer section (mystique settings > content). you really don't need a plugin to do that...

  11. MisaGarcia
    Member
    Posted 4 years ago #

    @ByteProject What happened to your workaround post... can't find it anymore.. did you just give up on this theme?

  12. MisaGarcia
    Member
    Posted 4 years ago #

    So really no one has solved this issue? Have been searching for a quite a while now, weeks and weeks.

  13. Bradley Allen
    Member
    Posted 4 years ago #

  14. silverwink
    Member
    Posted 3 years ago #

    Whether an application is blocked or not, self-control comes from within
    Ive been using http://bit.ly/bJwmma .
    It uses a better procedure than blocking social media sites because it only monitors sites like Twitter during production hours. People/Employees still have the option to use it for a breather or during breaks .
    Sometimes they use it for work too in helping reach decisions. For me its really unnecessary to block Twitter.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags