WordPress.org

Ready to get started?Download WordPress

Forums

Mysterious characters (5 posts)

  1. koolsheep
    Member
    Posted 9 years ago #

    OK -- I'm throwing in the towel. I am overall very happy with how my blog has gone together but I can't figure out one fairly simple thing. Go to my blog, click on the comments under one of my posts. See the question mark in the page title (in the browswer bar?) And also the question mark after "# Comments" (right above "The URI to TrackBack this entry is:" I want to get rid of those! My theory is that some non-ascii characters got into the code and the browser is choking on them. I already eliminated a few (it doesn't like those &#8212 em dashes). Anyway, I've grepped everything I can think of, and I can't find which file to look in to correct this text. I found what looked like the offending code in wp-comments-reply.php, but it was apparently not the right file.

    Oh, and the weird thing is, in my browser, if I hit refresh repeatedly, the ?'s alternate with >> which I assume is what the text is supposed to be.

    http://knitblog.thefegelmans.com

    Thanks for any help you can provide!

  2. koolsheep
    Member
    Posted 9 years ago #

    Bump. Can anyone help with this? Thanks!

  3. RustIndy
    Member
    Posted 9 years ago #

    Couple of quicky points for ya :)

    That funky little "?" next to the number of comments above the trackback line is simply part of the template you're using. I'm not sure exactly which file this is in in the 1.2 version, but it's probably "index.php", unless there's a "comments.php" file or something similar.

    It's probably an entity tag, like "©" and such. I don't know what that double-arrow one is, offhand, though. In my blog, I use the actual character instead of the entity tag and it's always worked fine.

  4. There seems to be quite a bit wrong (validation-wise) with your index.php template and/or index page posts. Cleaning it up may fix the problems. If not, it will make it easier to look for the problems that RustIndy is mentioning.
    http://validator.w3.org/check?uri=http%3A%2F%2Fknitblog.thefegelmans.com%2F

  5. rossz
    Member
    Posted 9 years ago #

    It's the >> character not displaying correctly. Try switching your character set to iso-8859-1 in your settings.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.