WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Mysterious border around dl/dt in widget (1 post)

  1. johnsalomon
    Member
    Posted 3 years ago #

    Hi,

    I'm using a theme that allows me to set up a Flickr thumbnails gallery inside posts with a shortcode.

    I'm trying to display the thumbnails gallery with the same layout in a widget. So far, I've managed to add a new widget area for posts, generate the shortcode in a PHP code widget based on a custom field in the post, and display pictures.

    Here is an example. The original thumbnail table is at the bottom of the post. The widgetized version is at right.

    I have the following two problems:

    - I can't get the grid layout working inside the widget (all images are stacked vertically). Even when I set up the default gallery to display a two-thumbnail-width grid, each row of two thumbnails displays in the widget as two images on top of each other (in the above example, the first two thumbnails in the widget are the two top ones in the post table)
    - the table has a weird border around each thumbnail in the widget that is not in the post.

    I've just spent a very frustrating time with Firebug trying to figure out which CSS elements deal with that border. I think it has to do with why the widget is not allowing the two images to show up next to each other.

    Can anyone give me a tip on how to get rid of that?

Topic Closed

This topic has been closed to new replies.

About this Topic