WordPress.org

Ready to get started?Download WordPress

Forums

mysql problem (9 posts)

  1. torweb
    Member
    Posted 9 years ago #

    I do have the correct mysql login information but am still getting the error to check my username, user password, etc.

    I've been looking at different applications and have installed the MoveableType blog application. It also needs mysql. I got that running fine with the exact same mysql info from my host provider.

    There has got to be another issue going on here...any help?

    Thanks

    Tom

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    There are two errors that WP gives - which one did you get ?

    Did you also check for any spaces in / before / after names?

  3. torweb
    Member
    Posted 9 years ago #

    Here's a copy of the error message followd by by config script. Again, this is the same mysql database info I used for MT (moveabletype) application which just 'popped' into action.

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at duke.
    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'you55'); // The name of the database
    define('DB_USER', 'you55'); // Your MySQL username
    define('DB_PASSWORD, '****'); // ...and password
    define('DB_HOST', 'duke'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    define('DB_HOST', 'duke')

    Are you absolutely certain that is correct ? It seems the weakest point right now.

  5. torweb
    Member
    Posted 9 years ago #

    Well, I just received confirmation from my host provider about mysql settings which are:

    MySQL Server : mysql.consultyou.net
    MySQL Database Name : Same as your Valueweb username
    MySQL Username : Same as your Valueweb username
    MySQL Password : Your MySQL password
    Port: 3306

    I entered the new MySQL Server above (instead of duke), but still am getting the same error message.

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    mySQL password ? That's the next possible culprit. Do you get to set that or was it provided ?

  7. torweb
    Member
    Posted 9 years ago #

    with my host provider, the pass word is the same one assigned when I established the account and is the one used to login to my control pannel. I've got several applications using mysql so I know it's working.

  8. YellowSwordfish
    Member
    Posted 9 years ago #

    I'm a newbie here but is this anything to do with the change to the hashing of passwords in newer versions of MySQL? Perhaps someone else can pick this up but I know I have had problems and have had to change the SQL query to use OLD_PASSWORD in more than one DB. It;s just a thought.

  9. torweb
    Member
    Posted 9 years ago #

    Hooooray! Well I did have everything correct, however it appears I had to reset my password, which I did with the same password. That fixed everything...

    Seems strange to me, but it fixed it.

    Thanks for the replies...

    Tom

Topic Closed

This topic has been closed to new replies.

About this Topic