WordPress.org

Ready to get started?Download WordPress

Forums

MySql not working via wp-config.php to my ISP (2 posts)

  1. kevinbc
    Member
    Posted 9 years ago #

    Hello, I have trolled thru these messages and the closest thing I can find to a problem similar to mine is:

    http://wordpress.org/support/topic/14546#post-84521

    where adding the port to the DB_HOST field fixed someone's problem.

    I've tried that, but to no avail. My ISP control panel gives me the DB_NAME, DB_USER & DB_HOST (and port) which I've put in wp-config.php tho still I get the error message saying one of those entries must be wrong.

    I have a control panel login to my MySql database via phpMyAdmin. I can login there with no problems, so I know the database is up and I've confirmed the DB_NAME, DB_USER and password. The only thing that could be wrong is the HOST (and/or port).

    Can anyone help me with some SQL commands I should run in phpMyAdmin to troubleshoot this further?

    I can ask specific questions to my ISP, but don't really know where to start. They say my HOST also has an alias, which they gave me. But that doesn't work either.

    Should it be a problem if my SQL database runs on a completely different server from where my website (wordpress installation) is hosted?

    cheers muchly,
    Kevin

  2. kevinbc
    Member
    Posted 9 years ago #

    nevermind, shool-boy error: I pasted an extra blank space at the end of my DB_USER. Doooh!

Topic Closed

This topic has been closed to new replies.

About this Topic