WordPress.org

Ready to get started?Download WordPress

Forums

My wordpress has decided not to work - can anyone help? (26 posts)

  1. Barfly
    Member
    Posted 6 years ago #

    I used fantastico to intall my wordpress, and usually without a problem, it's about the 4th time I've used it.

    Now on this occasion it's coming up with this on the dashboard

    "You don't have permission to access /wp-admin/index-extra.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at http://www.twisted-solutions.co.uk Port 80."

    Please can anybody help me resolve this issue. Thanks.

  2. Trent Adams
    Member
    Posted 6 years ago #

  3. Barfly
    Member
    Posted 6 years ago #

    sorry for not checking first :-S

  4. Barfly
    Member
    Posted 6 years ago #

    I have followed that, and it has not helped.

    Any ideas?

  5. Trent Adams
    Member
    Posted 6 years ago #

    Have you checked the permissions on your wp-admin directory?

    Trent

  6. Barfly
    Member
    Posted 6 years ago #

    I thought about that, but then decided I wouldn't actually know what they were meant to be... currently they are:

    755

    should they be 777?

  7. moshu
    Member
    Posted 6 years ago #

    No, 755 should be fine for the wp-admin folder.
    Are you sure you placed the 2 line htaccess mentioned in the linked thread in the wp-admin folder and not somewhere else?

  8. Barfly
    Member
    Posted 6 years ago #

    yeah, I admit that firstly I named it wrong, then secondly I placed it in /wp-admin. But now it is in public_html

    Am I just doing this all wrong??!

  9. moshu
    Member
    Posted 6 years ago #

    Yes. All wrong. Name it correctly and place it in the wp-admin - that's what they say in the other thread! Don't reinvent the wheel...

    EDIT. p.s. the public_html should have it's own htaccess if your WP is installed there and you use nice permalinks. Don't mix the two files!

  10. Barfly
    Member
    Posted 6 years ago #

    What should be in the htaccess in the public html then seeing as I've distroyed it...?

  11. Barfly
    Member
    Posted 6 years ago #

    and no, that didn't work either... grrr!

  12. Barfly
    Member
    Posted 6 years ago #

    If I create a file in notepad and save it as 'all files' called '.htaccess.' - It doesn't work...

    If I create a text file and upload it .txt then rename it '.htaccess' It doesn't work...

    I really don't understand...!

  13. moshu
    Member
    Posted 6 years ago #

    Since you are not using the nice permalink - there should NOT be any .htaccess file in your root folder (public_html).

    So, what do you have in the .htaccess file in your wp-admin/ folder?
    Is the file named correctly? Notice the . [dot] at the beginning!
    .htaccess

  14. Barfly
    Member
    Posted 6 years ago #

    Moshu, I appreciate your patience... even though I'm starting to loose mine!

    I no longer have a .htaccess in the root folder. I manually added one, now I have deleted it.

    Now in wordpress admin I have .htaccess file named .htaccess
    - in that is this:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    Pleeeease can you spot where I am going wrong. I'll even upload a picture of my FTP and notepad and everything if it would help?!

  15. moshu
    Member
    Posted 6 years ago #

    What you described above and the code in the file seem to be the right thing. Now it is my turn to get confused why it doesn't work...

    (on one server I also had this issue but it was solved easily applying that fix)

  16. Barfly
    Member
    Posted 6 years ago #

  17. moshu
    Member
    Posted 6 years ago #

    If the left side is your host server - it seems to be in the right place.

  18. Barfly
    Member
    Posted 6 years ago #

    yuppy!

  19. Barfly
    Member
    Posted 6 years ago #

    this is the error I now get in the sidebar 'latest activity' and where the wordpress updates go, and if I try to edit/delete anything like comments, or add categories.

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@twisted-solutions.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at http://www.twisted-solutions.co.uk Port 80

  20. Barfly
    Member
    Posted 6 years ago #

    If I take everything out of the htaccess file, the original error comes up:

    Forbidden
    You don't have permission to access /wp-admin/index-extra.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at http://www.twisted-solutions.co.uk Port 80

    By the way, this happened on another test blog I set up for my boyfriend this evening too... I used fantastico to install it... I don't think I could provide ANY other information. Except I currently use an older version on my other domain and that works perfectly.

  21. moshu
    Member
    Posted 6 years ago #

    We will need some more knowledgeable helpers here... that know more about .htaccess and the error logs mentioned in the error message.

    Let's hope they will come around.

  22. Barfly
    Member
    Posted 6 years ago #

    Hmmm... If somebody tells me how to access the error logs I will give em a look over... is it in the cpanel?

  23. Barfly
    Member
    Posted 6 years ago #

    ah ha!

    : error: file is writable by others: (/home/twistsol/public_html/wp-admin/index-extra.php)
            [error] [client 66.232.112.194] File does not exist: /home/twistsol/public_html/404.shtml
     [error] [client 66.232.112.194] script not found or unable to stat: /home/twistsol/public_html/form.php
     [error] [client 65.214.45.142] [Mon Oct 22 21:08:21 2007] [alert] [client 82.3.204.206] /home/twistsol/public_html/wp-admin/.htaccess: <IfModule takes one argument, Container for directives based on existance of specified modules
    [error] [client 82.3.204.206] File does not exist: /home/twistsol/public_html/500.shtml
    [alert] [client 82.3.204.206] /home/twistsol/public_html/wp-admin/.htaccess: <IfModule takes one argument, Container for directives based on existance of specified modules
    [alert] [client 82.3.204.206] /home/twistsol/public_html/.htaccess: <IfModule takes one argument, Container for directives based on existance of specified modules
    [alert] [client 82.3.204.206] /home/twistsol/public_html/.htaccess: Invalid command '\xff\xfe<', perhaps mis-spelled or defined by a module not included in the server configuration
     [error] [client 82.3.204.206] File does not exist: /home/twistsol/public_html/500.shtml
    [alert] [client 82.3.204.206] /home/twistsol/public_html/.htaccess: Invalid command '\xff\xfe<', perhaps mis-spelled or defined by a module not included in the server configuration
     [error] [client 82.3.204.206] File does not exist: /home/twistsol/public_html/500.shtml
     [error] [client 82.3.204.206] Premature end of script headers: /home/twistsol/public_html/wp-admin/index-extra.php

    EDIT i tried to compress it a little.

  24. Chris_K
    Member
    Posted 6 years ago #

    See this thread: http://wordpress.org/support/topic/132667

    As you read deeper into it, you'll see some other .htaccess options you might try.

  25. Barfly
    Member
    Posted 6 years ago #

    Thank you very much handysolo, it seems that

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    fixed it, where It wasn't working yesterday though and I only pasted it in one more time before I gave up... Confused.

    Thank you everyone. Your help is appreciated.

  26. arjunshrivatsan
    Member
    Posted 5 years ago #

    Hello,

    I had a problem very much related to this. I was following the threads keenly especially from Moshi and linked threads.

    I must really appreciate the help. The fixes worked like a charm for me.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic