WordPress.org

Ready to get started?Download WordPress

Forums

My website is too slow- 404 Errors wierd (2 posts)

  1. ahmar2
    Member
    Posted 1 year ago #

    Hi,
    I am using Latest version of the website and a theme from themefuse. The problem is that my website takes ages to load. This is not a hosting related issue as after conducting several speed tests it is obvious that issue is caused due to the strange 404 errors. The problem is that all the files are there and there are no bad requests but even though I get broken links errors on speed tests and these requests increase the load time exponentially.
    Here is the URL to the speed test:
    http://tinyurl.com/cqf7qxf

    Here is my website:
    http://hostingsheep.com

    I think it has something to do with .htaccess after I changed the permalinks but this is just an idea and I am not too sure. As you can see from the test result above there are multiple broken links to the css and js files. Both folders have 777 permissions.

    Any help would be appreciated,
    Regards,
    Ahmar.

  2. s_ha_dum
    Member
    Posted 1 year ago #

    I don't see any 404 errors, neither in my browser or here.

    I do see that your site is making quite a few requests, including five requests for font files (which alone consume a little more than a full second), 32 Javascript files, and 12 stylesheets. I am actually impressed that your server handles it as well as it does.

    Looks like all of your scripts are loading in the <head>. I am sure some could be loaded at the bottom of the page. Your theme is loading a bunch of little images. Those could be combined into a sprite, or sprites and reduce the number of requests.

Topic Closed

This topic has been closed to new replies.

About this Topic