WordPress.org

Ready to get started?Download WordPress

Forums

my WebServer without "/" (14 posts)

  1. qzplx
    Member
    Posted 9 years ago #

    Hello,

    i dont know the reason why i always have to use this / to access my
    site from webserver, its currently a local site in LAN

    ex :

    http://jakserv.jaktv.net/internal ----> will error page not found
    http://jakserv.jaktv.net/internal/ ----> good

    did anyone know how to fix this ??

    thanks

  2. There is a way to configure Apache to fix that, but I don't know it. In the mean time, put this in your main .htaccess file:

    Redirect permanent /internal http://jakserv.jaktv.net/internal/

    Bloody board formatting ... :( The above example should be all on one line with a space between /internal and http://.

  3. skippy
    Member
    Posted 9 years ago #

    Apache 1.x solution.
    Apache 2.x solution.

  4. qzplx
    Member
    Posted 9 years ago #

    thanks......

    after i read the links that u given....
    i still dont know what should i do ??

    sorry, now i understand the problem, but what should i do next ?

    thanks

  5. qzplx
    Member
    Posted 9 years ago #

    ups...sorry, i cant create any .htaccess in windows ? its error filename ??

  6. ptaylor
    Member
    Posted 9 years ago #

    create the file with any name on your computer and then rename to
    .htaccess after you have uploaded it, at least thats what i do.

  7. qzplx
    Member
    Posted 9 years ago #

    nope....its on my LAN server, its on localhost....

  8. roterhund
    Member
    Posted 9 years ago #

    I have the same problem. I tried to modify the blog's address in admin->options, but WP always cuts that end slash »/«. Also on LAN.

  9. WordPress will always cut the end slash, there's really no way around that. What you need to do is configure Apache to redirect directories entered as this: /directory to this: /directory/ . Apache should be configured this way by default.

  10. roterhund
    Member
    Posted 9 years ago #

    Looks like mine isn't. Will try to fix that. Thanks!

  11. qzplx
    Member
    Posted 9 years ago #

    i try with this...

    Redirect http://localhost/internal http://localhost/internal/

    is it works...

    wait my report

  12. qzplx
    Member
    Posted 9 years ago #

    hi guys....its still doesnt work at apache ?
    any idea ???

  13. roterhund
    Member
    Posted 9 years ago #

    I gave up. It's just for local testing between my PC and the Mac anyway. Apache is configured to put the slash at the end. No idea what's going wrong. And no more time to waste on the issue. Maybe WordPress could just leave the slash where I put it, in some future version…

    Another thing I don't understand is why sometimes the address will be the IP (numbers) and sometimes »localhost«. So many mysteries unsolved :-)

    Thanx all for trying to help!

  14. liyoung
    Member
    Posted 8 years ago #

    I have exactly the same problem, and after browsering tons of discusion and documents, finally I figure it out!

    there is NO use setting .HTACCESS
    Redirect /internal http://localhost/internal/

    as this page says,
    http://httpd.apache.org/docs/1.3/misc/FAQ.html#set-servername
    you have to add this line in your httpd.conf:
    servername 123.456.789.123(your ip)

    BEWARE
    servername http://123.456.789.123/
    causes a FAILURE......that's my problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.