WordPress.org

Ready to get started?Download WordPress

Forums

My static/front page keeps getting redirected to a previous, deleted page! (12 posts)

  1. leylap
    Member
    Posted 4 years ago #

    Hi,

    Sorry to be a pain, but I created a page called, http://www.motherhooddiaries.com/articles/21-june-2010 (not a post or static page), then deleted it when I typed http://www.motherhooddiaries.com into a browser and found that it would automatically redirect to the deleted url. Unfortunately, now when I do type http://www.motherhooddiaries.com, it redirects to the deleted url and I can't get the front page back :-(

    Can anyone help me? I'm a first time user and so not very familiar with wordpress in order to amend this issue. If you could be as descriptive as possible that would be really great.

    Thank you all in advance!

  2. leylap
    Member
    Posted 4 years ago #

    Also, I think there may be something wrong with the actual theme now. I initially had the coffee desk theme and everything was working fine. But now that I've installed the Wooden Fence theme, I can't do the above and I can't seem to edit the time and date of a post... Odd...

  3. CSWebmaster
    Member
    Posted 4 years ago #

    I had the same issue. Unfortunately, the only way I could seem to fix it was to restore the database from a backup

  4. leylap
    Member
    Posted 4 years ago #

    Ok thanks. Good job I backed up just before I changed themes. However, it's quite possible that this will happen again, as I have a feeling it's something to do with the theme itself...

  5. leylap
    Member
    Posted 4 years ago #

    Can you restore from backup in wordpress or would you have to restore from your host server?

  6. CSWebmaster
    Member
    Posted 4 years ago #

    To restore the database you usually do it via your hosts control panel.

    (Should be the same place where you backed it up!)

    However, make sure you have tried de-activating all plugins you have on your site before doing anything else to see if that fixes the issue. Then you may be able to narrow it down to it being a plugin issue and not a WordPress one.

    I tried this to no avail, but some people seem to be having these redirection issues because of incompatible plugins.

  7. leylap
    Member
    Posted 4 years ago #

    Great thanks CSWebmaster. I'll give that a shot. And if it doesn't work, I'll restore.

  8. esolano
    Member
    Posted 4 years ago #

    Hi, I think the problem is with the Redirection plug-in. I did what this post says, and now it works. http://urbangiraffe.com/support/topic/home-page-is-redirecting-to-another-wp-page-without-my-instruction-to-do-so?replies=6#post-3960

    Now, don't forget to use the latest version of the Redirection plug-in, and to delete all occurrences of the bad redirection records in the "redirection_items" table. Those are the ones causing the home page redirect to your newly created posts, the ones with "/" in the url filed.

    I hope this helps.

  9. Geoff Snyder
    Member
    Posted 4 years ago #

    I had the same problem for several days. Oddly, it was a new plugin that triggered it and I had a new page keep looping from my front page. It was annoying as for I knew it was something small and silly...just like this.

    Thank you esolano!!!

  10. leylap
    Member
    Posted 4 years ago #

    Fantastic!! Thank you guys. It worked! I followed Brad's advice then deactivated the redirection plugin:

    "Brad:
    Posted 1 day ago by Member

    This is an issue with the update to Redirection setting up automatic redirects....called 'Monitoring'.

    It's nice for a site that has been around for awhile, but in development, it can kill your site and your head.

    In your Dashboard: Go to Tools -> Redirection -> Options. Find 'URL Monitoring' and set 'Post & Page URLS' to 'Don't Monitor'

    Hope this helps."

  11. AmyCelona
    Member
    Posted 4 years ago #

    @leylap - THANK YOU SO MUCH FOR THIS! This happened to me yesterday on one of my sites and I KNEW that I didn't create that re-direct!

    If I hadn't seen this today it would have happened again, I have turned OFF the monitoring setting.

  12. leylap
    Member
    Posted 4 years ago #

    Brad is who helped :-)

    I have another issue now. I'm trying to change the registration page so it doesn't have the default page. I want to include my logo on there instead. Any ideas? Let me know if you have the same issue as I'll send you the answer too if I can find it!

Topic Closed

This topic has been closed to new replies.

About this Topic