WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] My Sitemap Has No Styling (20 posts)

  1. kmcminn
    Member
    Posted 7 months ago #

    Hello, I'm not sure when this happened, but I just noticed that my sitemap has absolutely no styling and the XML formatting is completely gone. Could someone please take a look at this and point me in the right direction?

    http://www.nintendonews.com/sitemap.xml

    Thanks,
    Kevin

    http://wordpress.org/plugins/w3-total-cache/

  2. harmonyinfotech
    Member
    Posted 7 months ago #

    The xsl file is having 403 Forbidden error.
    http://www.nintendonews.com/wp-content/plugins/google-sitemap-generator/sitemap.xsl

    Try copying that in root folder and see if you are able to access it. It could be due to some permission issues.

  3. kmcminn
    Member
    Posted 7 months ago #

    Hello, harmonyinfotech.

    Thanks for your reply. I appreciate your suggestion, but that's not one of the steps outlined in the plugin's installation directions.

    The sitemap generates correctly and is recognized by Google. So, I'm really not too sure what's going on. All I know is that the XML formatting is non-existent. I'm not sure if this is fault of the W3 Total Cache plugin, or the Google Sitemap Generator plugin.

  4. harmonyinfotech
    Member
    Posted 7 months ago #

    The sitemap styling will be applied when that file is properly readable. As the file isn't readable currently (403 error), the styles aren't getting applied to sitemap.xml because of which you aren't able to see any styling. The suggestion to copy it to root folder and then load it at http://www.nintendonews.com/sitemap.xsl will clarify if there is problem with file permissions somewhere or server configuration.

  5. harmonyinfotech
    Member
    Posted 7 months ago #

    I understand it isn't part of installation directions and in normal situation there is no need to do it but since you are having problem, it is just a way to debug and find out what could be the underlying issue.

  6. kmcminn
    Member
    Posted 7 months ago #

    OK, I see.

    I copied the xls file to the root of my blog and now I see this.

    http://www.nintendonews.com/sitemap.xsl

  7. harmonyinfotech
    Member
    Posted 7 months ago #

    Ok, the file is readable at root folder. Chances are the .htaccess must be blocking files in plugin folders (The rule could have been applied because of security plugin).

  8. kmcminn
    Member
    Posted 7 months ago #

    Hmm, so what would be your next recommendation?

  9. harmonyinfotech
    Member
    Posted 7 months ago #

    In the sitemap settings, under Advanced options, disable "Use default" for "Include a XSLT stylesheet" and just keep sitemap.xsl there and save it. It will load the stylesheet from the root folder then.

  10. kmcminn
    Member
    Posted 7 months ago #

    OK, I unchecked the "Use default" option for the "Include a XSLT stylesheet"

    Am I supposed to fill anything in for this?

    "Full or relative URL to your .xsl file"

    ...it's currently blank.

  11. harmonyinfotech
    Member
    Posted 7 months ago #

    Yes, put sitemap.xsl there so that it will read it from the root folder which you copied earlier.

  12. kmcminn
    Member
    Posted 7 months ago #

    Whoa! Now THIS is what it's supposed to look like, right?

    http://www.nintendonews.com/sitemap.xml

  13. harmonyinfotech
    Member
    Posted 7 months ago #

    Yes.

  14. kmcminn
    Member
    Posted 7 months ago #

    I've learned a lot from you today, harmonyinfotech. I appreciate your diligence and timely responses. I'm hoping someone else who has the same issue finds this topic so they too can resolve their issue. Thanks again!

  15. harmonyinfotech
    Member
    Posted 7 months ago #

    You are welcome. Solving issues like this helps in improving my own skillsets.

  16. kmcminn
    Member
    Posted 7 months ago #

    One final question for you. While validating my sitemap, I receive this warning:

    "Missing "charset" attribute for
    "text/xml" document."

    Is that something I can disregard?

  17. harmonyinfotech
    Member
    Posted 7 months ago #

    Yes, it can be ignored.

  18. kmcminn
    Member
    Posted 7 months ago #

    OK. Good. I'm marking this as resolved. Thanks again for your time, harmonyinfotech. By the way, do you offer WP help outside of the support forums?

  19. harmonyinfotech
    Member
    Posted 7 months ago #

    Yes, we do provide paid wordpress support. You can search for us in google.

  20. kmcminn
    Member
    Posted 7 months ago #

    Got it. Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags