WordPress.org

Ready to get started?Download WordPress

Forums

My site is not getting indexed in google, and everything looks in order, help! (3 posts)

  1. bonini81
    Member
    Posted 1 year ago #

    Hello while is was i builing my site, i chose from the Privacy setting in WordPress to not allow search engines to crawl my site, for obvious reasons cause the site was being build.

    But after i finished my site which was like 3 weeks ago i went to privacy settings and chose to let the crawlers index my site and when i go to Google to see if my URLs are indexed i get this message: A description for this result is not available because of this site's robots.txt
    And my robots.txt seems fine, i am not blocking anything and there are no, noindex meta tags...It looks like Google still thinks i dont allow them to crawl my site...WTF, has anyone had this problem? I all pass the info of my site in case anyone is curious, by the way only the homepage is indexed but i have more than 40 URLs which are not.
    Site: http://www.pelituber.com/
    robots: http://www.pelituber.com/robots.txt

    Any ideas what can i do or might the problem???

  2. justingreerbbi
    Member
    Posted 1 year ago #

    Google can take a ton of time to refresh its cache.

    - robots.txt seems to be fine. May just have to wait a bit longer. Other people have had this problem as well. Do a search on the forums and most of them have been resolved already (Came down to waiting). I know 3 weeks is not that long of a time when it comes to being indexed by google.

  3. bonini81
    Member
    Posted 1 year ago #

    Thanx man, i am surprised that googles cache can take so long, especially after the Google Caffeine algorithm change allows them to index a lot of stuff in days, cant believe the cache is so slow to refresh, thanx anyways i all keep waiting, being so more than a month...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.