WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] My RSS Feed doesn't have a Title (8 posts)

  1. lilypetals
    Member
    Posted 7 years ago #

    ...especially in Bloglines. When I subscribe to my feed, the entry only shows up as blog URL for the title, but not a real title as I would've liked. Can anyone help with this? Where do I go to insert some text for the title?

    I figured it was in the "wp-rss.php" file:

    <title><?php bloginfo_rss('name') ?></title>

    and by changing 'name' to whatever title I want would change it, but I tried that, yet NOTHING.

    Thanks much!

  2. Chris_K
    Member
    Posted 7 years ago #

    Logged in as admin, what you see at Options -> General for title (the very top field there) should be what's in your feeds (assuming you put it back to default).

  3. lilypetals
    Member
    Posted 7 years ago #

    No, putting a title there only puts it on my blog's header, which overlaps my logo. And then in the title bar of the browser, it also places the text next to the already existed title I had placed in the php file. I hope that made sense. Basically, putting title in the Options > General section will only overlap what I already had.

  4. Chris_K
    Member
    Posted 7 years ago #

    Ya know... if you specified a title at Options -> General and then just modified the theme's stylesheet to hide it, you'd gain some benefits.

    1) SEO - spiders would see a real H1 title (they don't "read" images).

    2) Anywhere that your blog displays a title would, well, have a title. No hacks or modifying of core files needed.

    2.5) Remember, every time you modify a core file, you get to redo it after every WordPress upgrade.

    Summarized: if you had a title there, styled to be hidden, you'd be working fine without modifying core stuff.

  5. lilypetals
    Member
    Posted 7 years ago #

    >>Ya know... if you specified a title at Options -> General and then just modified the theme's stylesheet to hide it, you'd gain some benefits.<<

    How do I hide it?

    WEll, is there any alternate way to simply put a title on the RSS Feed?

  6. Chris_K
    Member
    Posted 7 years ago #

    In the CSS for the title, add
    display: none;

    For your theme, I'd look at #header-title I think.

  7. lilypetals
    Member
    Posted 7 years ago #

    I tried, but didn't work. :(

  8. lilypetals
    Member
    Posted 7 years ago #

    OK I figured it out. Simply do this:

    1) Open and edit both "wp-rss.php" and "wp-rss2.php" files

    2) Somewhere towards the top, find:

    <channel>
    <title><?php bloginfo_rss('name') ?></title>
    <link><?php bloginfo_rss('url') ?></link>
    <description><?php bloginfo_rss("description") ?></description>

    3) Get rid of everything inside the title tags, which is:

    <?php bloginfo_rss('name') ?>

    and simply replace with

    <title>YOUR OWN TITLE HERE</title>

    That's it! Now your Feeds will show up in Bloglines with your own title.

    [I think all that does is grab whatever info WordPress has in your Dashboard, so if you manually put it in, that'll work, too.]

Topic Closed

This topic has been closed to new replies.

About this Topic