WordPress.org

Ready to get started?Download WordPress

Forums

Twitter posts to Blog
[resolved] My posts are stuck on UTC and also getting duplicates (8 posts)

  1. craynkshaft
    Member
    Posted 1 year ago #

    I didn't see a setting in the plugin to set my timezone, but my WP timezone settings are correct. I'm UTC -7 and everything else appears correct.

    The reason this is an issue is because all new tweet-posts are going into "Scheduled" rather than "Published". I tried adjusting the settings to push the new tweets to "Draft" (that worked), then back to "Published" (that didn't). When I open one of the scheduled tweet-posts in the editor, it shows that it's schedule to be published seven hours later (UTC time).

    Also, I'm getting several duplicates popping up sporadically. And yes, I have RT's and @replies turned off. What gives?

    http://wordpress.org/extend/plugins/twitter-posts-to-blog/

  2. badbreze
    Member
    Plugin Author

    Posted 12 months ago #

    you're self hosted?

  3. d0nk3y
    Member
    Posted 11 months ago #

    The timezone is hard-coded to UTC so it defaults to this regardless of what your wordpress is set to.

    Edit the code using the plugins editor (admin.php I believe, don't have the code in front of me) and change the date_default_timezone_set to the correct timezone listed here.

  4. d0nk3y
    Member
    Posted 11 months ago #

    Sorry, it's in twitter-posts-to-blog.php - 8th line down.

  5. badbreze
    Member
    Plugin Author

    Posted 11 months ago #

    Removed timezone from code

  6. acostanza
    Member
    Posted 11 months ago #

    I don't know why or how, but I have the same problem where Tweets are getting scheduled for UTC time. I have deactivated and reactived the plugin, still getting scheduled instead of posting instantly. I double checked the version and I have 1.4.6.2 I also checked my WP Settings time for the server and it is set to NY timezone, which is mine. Any ideas on how to make the tweets post right away instead of being scheduled?
    Thanks!

  7. acostanza
    Member
    Posted 11 months ago #

    Update: Fooling around with the UTC offset in the Network Admin (this is a site in a WP Network install) does nothing. However, changing the UTC offset in the Settings does cause the Tweet to be posted immediately. While this is a short-term workaround, the server time is now 5 hours off and so are the posts. Any insight is appreciated!

  8. badbreze
    Member
    Plugin Author

    Posted 11 months ago #

    update to latest version this may solve your problem

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic