WordPress.org

Ready to get started?Download WordPress

Forums

PB Responsive Images
My patht to the image is broken... (16 posts)

  1. oneguy
    Member
    Posted 1 year ago #

    Hi and thank you for the plugin

    This is my Temp site -
    http://80.179.140.91/~orgad/?page_id=11003

    I cannot see the images on the page once I activate your plugin.

    This is the path
    http://80.179.140.91/~orgad/slirw584/wp-content/uploads/2012/09/IP56.jpg

    This is the path that should be instead
    http://80.179.140.91/~orgad/wp-content/uploads/2012/09/IP56.jpg

    So basically it adds - "/slirw584"

    I put the code in the .htaccess .

    RewriteRule ^slir(.*)$ /wp-content/plugins/pb-responsive-images/slir/index.php?r=$1 [L]

    and put this code in the base url in he settings page

    {base-url}/slir

    How can I put the code so it finds the correct path?

    Thanks

    Guy

    http://wordpress.org/extend/plugins/pb-responsive-images/

  2. oneguy
    Member
    Posted 1 year ago #

    Anyone?
    Please?

  3. oneguy
    Member
    Posted 1 year ago #

    Hi Jacob
    I really need help in setting the plugin -
    I didn't understand what to do with the plugin and how to set it up.
    I need to finish a web site for my client and I wouldn't find any other solution.
    Thanks
    Guy

  4. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    Geeze oneguy, sorry for not answering this. I rely on an RSS feed to notify me of requests, but it appears that this thread wasn't added...something odd going on with WordPress.org.

    As to your issues, it appears that you missed a trailing slash in the base URL. You should be using the following, instead:

    {base-url}/slir/

    If that still doesn't work (the site being in a subfolder, and the tilde in the url may be causing issues) then you can use the following base URL as a quick fix:

    {plugin-url}/slir/index.php?r=

    Sorry for the huge delay - I got back to you as soon as I found out about the post, but that may have been two weeks too late. Let me know if that fixes the issue, if you're still using the plugin.

  5. oneguy
    Member
    Posted 1 year ago #

    Oh Thank You Jacob!
    Still no good news....

    Besides activating the plugin and putting this line on the setting and saving the changes - Do I need to do anything else?

    After I'm saving I get this sentence instead -

    http://80.179.140.91/~orgad/slir/

    Also My .ataccess fie looks like that -

    # BEGIN WPResponsiveImages

    RewriteRule ^slir(.*)$ /wp-content/plugins/pb-responsive-images/slir/index.php?r=$1 [L]

    # END WPResponsiveImages

    # BEGIN WordPress

    # END WordPress

    Anything Else I need to look for?

  6. oneguy
    Member
    Posted 1 year ago #

    Sorry -

    .htaccess :)

  7. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like you don't have pretty permalinks enabled for WordPress at all. I'd go ahead and use the following base url, instead:

    {plugin-url}/slir/index.php?r=

    That should fix it - no need to mess with rewrites if you aren't using them for your pages.

  8. oneguy
    Member
    Posted 1 year ago #

    Thanks!

    I'm using now permalinks, but even without permalinks I get this sentence after saving the setting with

    {plugin-url}/slir/index.php?r=

    transformed into -

    http://80.179.140.91/~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=

    This is the path to the image -

    http://80.179.140.91/~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=w584/wp-content/uploads/2012/07/cooper.jpg

    Maybe you can help better if you will have access to my admin?

    Thanks a lot for all the help - this is really important for me!

  9. oneguy
    Member
    Posted 1 year ago #

    Besides all this - Do I need to alter anything in the code inside the theme?

  10. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    You shouldn't have to alter anything. That path to the image is correct, it looks like you have another error occurring. I can't tell what it is from the generic error screen, but it may be related to a bug I've found with wordpress being hosted out of a subfolder. I'm going to be doing some testing on my own, to see if I can replicate and correct it. However, if you could find out the specific error message being thrown, it may help.

  11. oneguy
    Member
    Posted 1 year ago #

    I don't really know how to look for errors.
    Still- I fit will help you get into the admin - Just tell me...
    Or maybe we should just wait for the site to go live?
    Thanks
    Guy

  12. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    Ok - I've resolved a new bug with subdirectory installs. If you'd like to try that out, it's available here:

    http://downloads.wordpress.org/plugin/pb-responsive-images.1.4.zip

    If that doesn't work, we can look at how to find those php errors for you.

  13. oneguy
    Member
    Posted 1 year ago #

    Thanks.

    It still doesn't work...

    I looked into my .htaccess file and saw that a dew lines were added there -

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~orgad/
    RewriteRule ^index\.php$ - [L]
    RewriteRule ^wp-content/plugins/pb-responsive-images/slir/index.php?r=([^/]*)/(.*)$ /~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=$1/~orgad/$2 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~orgad/index.php [L]
    </IfModule>

    Is that right?

    Now I get this sentence -

    http://80.179.140.91/~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=

    The image path is this -

    http://80.179.140.91/~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=w584/wp-content/uploads/2012/09/DAF-MOZAR-BUTTON.jpg

    http://80.179.140.91/~orgad/%D7%9E%D7%95%D7%A6%D7%A8%D7%99%D7%9D/%D7%AA%D7%90%D7%95%D7%A8%D7%AA-%D7%97%D7%95%D7%A5/%D7%AA%D7%90%D7%95%D7%A8%D7%AA-%D7%9B%D7%91%D7%99%D7%A9%D7%99%D7%9D-%D7%A8%D7%97%D7%95%D7%91%D7%95%D7%AA/rc-led/

    ThANKS FOR YOUR EFFORT!

    Guy

  14. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    Lol. Excellent. That .htaccess rule shouldn't insert, I'll have to look at that. Go ahead and delete the following line:

    RewriteRule ^wp-content/plugins/pb-responsive-images/slir/index.php?r=([^/]*)/(.*)$ /~orgad/wp-content/plugins/pb-responsive-images/slir/index.php?r=$1/~orgad/$2 [QSA,L]

    We don't want that extra complexity right now, it would be nice to just see an image, right?

  15. oneguy
    Member
    Posted 1 year ago #

    OK
    Now there is only this there -

    # BEGIN WPResponsiveImages

    # END WPResponsiveImages

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~orgad/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~orgad/index.php [L]
    </IfModule>

    # END WordPress

    What should I try to write in the setting page of the plugin?
    Still can't see the images...

    This is like a mystery tale...

  16. Jacob Dunn
    Member
    Plugin Author

    Posted 1 year ago #

    Well, that .htaccess file looks fine, now. We're bypassing it, so this isn't the issue. We DO need to find out what actual error you're throwing. Try pasting the following into the index.php file throwing the error:

    ini_set('display_errors', 1);
     ini_set('log_errors', 1);
     ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
     error_reporting(E_ALL);

    That should output the error. For the future, I'd recommend on getting your server configuration set up to display errors if you're using it for development. If the script above doesn't show the relevant errors, it may be worth googling php error reporting to get that set up.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags