WordPress.org

Ready to get started?Download WordPress

Forums

My pages are not working, 404 error (17 posts)

  1. Leogeo
    Member
    Posted 8 years ago #

    Hi,

    When i created my pages in wordpress, they apear in sidebar under the head of Pages. But when i try to open them by clicking there, it does not open but error comes, Page Not found, plz help me to fix this problem,

    here is link http://www.acmeaims.com/daily

  2. Samuel B
    moderator
    Posted 8 years ago #

    Your site looks fine to me.

  3. th3gh05t
    Member
    Posted 7 years ago #

    Hi,

    I am also experiencing this problem. I just moved my blog to a new webhost, and now the only thing that isn't working with WP is the pages.

    I just get a plain old 404 error.

    Please help me out! (http://www.derekrossler.com/about-me/)

    Thanks, Derek

  4. moshu
    Member
    Posted 7 years ago #

    Did you reset your permalinks and .htaccess file at the new location?

  5. th3gh05t
    Member
    Posted 7 years ago #

    i dont have a .htaccess file

    where can i get one?

    where is the standard file?

  6. flammobammo
    Member
    Posted 7 years ago #

    Leogeo your site works fine for me too.

    Theghost how are you hosting the site? The .htaccess file should be in your root directory and have writeable access for WordPress. Search for .htaccess issues in these forums or just start by uploading 1.htaccess via ftp, and then renaming it to .htaccess once you've uploaded it. (Windows won't allow such a filename) Then change the file permissions appropriately. Hopefully this should be a good reference for you to work from.

  7. th3gh05t
    Member
    Posted 7 years ago #

    Yea, thats great and all. I know what an .htaccess file is, and I know how they work.

    I just need an EXAMPLE of one.

    Thanks, th3gh05t

  8. Samuel B
    moderator
    Posted 7 years ago #

    Got to:
    admin -> Options -> permalinks
    Choose your permalink poison. Look in text box at bottom. That's what goes in your .htaccess.

  9. th3gh05t
    Member
    Posted 7 years ago #

    Well, I want the "default" permalink structure. When I select this option, nothing shows up in the text box.

    Even when I select a different structure, and paste that into the .htaccess file, it still doesn't work. It gives me a 'Internal Server 500 error', instead of a the regular 404.

    Here is what I want:

    1. I want the default link structure.
    2. I want my pages to work.

    I don't understand why this is so difficult to accomplish.

    Thanks for your time!

    th3gh05t

  10. Samuel B
    moderator
    Posted 7 years ago #

    Paste the contents of your .htaccess file.

  11. th3gh05t
    Member
    Posted 7 years ago #

    The contents of my .htaccess file are empty.

    If you look in my previous posts, you will see that this is what I have been asking for all along.

  12. Chris_K
    Member
    Posted 7 years ago #

    What is your web server? Apache or IIS or .. ?

    Have you visited this page in the Codex? Lots of troubleshooting stuff in there:

    http://codex.wordpress.org/Using_Permalinks

    In particular, if you're apache based, does your host have mod_rewrite enabled AND "allowOverrides" turned on?

  13. th3gh05t
    Member
    Posted 7 years ago #

    It is an Apache web server. I have looked at the Codex, but I have found nothing where it gives an example of what should be in the the .htaccess file.

  14. Chris_K
    Member
    Posted 7 years ago #

    In particular, if you're apache based, does your host have mod_rewrite enabled AND "allowOverrides" turned on?

    And the answer to that quoted bit?

    If you visit your Permalinks page -and- WP decides it can't write to your .htaccess file, it will show you (bottom of page) what should be put in. If WP can write to your .htaccess, it will update it for you and you can see the results when you edit your .htaccess.

  15. th3gh05t
    Member
    Posted 7 years ago #

    Hi,

    I have contacted my webhost. and they have activated mod_rewrite enabled AND "allowOverrides".

    When I click on "Update Permalinks", it says that the Permalink structure has been updated. There are no errors, and there is nothing on the bottom of the page.

    When I try and edit the (.htaccess) file through the wp-admin, I get this page:

    Not Acceptable
    An appropriate representation of the requested resource /wp-admin/templates.php could not be found on this server.

    Apache/1.3.34 Server at http://www.derekrossler.com Port 80

    I do not know what else to do.

    Please help me so that I can get my pages working!!!

  16. moshu
    Member
    Posted 7 years ago #

    When I try and edit the (.htaccess) file through the wp-admin

    Don't try. Either make it writable (chmod 666) and let WP write to it, or copy/paste the rules WP gives you into the file on your computer and upload it.

  17. Christopher J. Hradil
    Member
    Posted 7 years ago #

    This looks like a similar problem to a couple of other posts lately. Check to see if your host has the MS Frontpage extensions installed, and/or mod_frontpage is compiled with apache. I came up with a fix for this issue late last night after a couple of other folks ran into similar issues with Frontpage extensions. I've updated the codex permalinks section with instructions for a fix should this turn out to be the issue see --

    http://codex.wordpress.org/Using_Permalinks

    From what you're describing, it sounds like you're breaking the FP extension install with the wp re-write rules, which is why you're getting the 404's. See the codex towards the middle of the page.

    later...chris

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags