WordPress.org

Ready to get started?Download WordPress

Forums

my page-template option disappeared!! (4 posts)

  1. razgrizofender
    Member
    Posted 2 years ago #

    I'm using twentyten as my template and make a custom-template for one of my page. there is no problem up to this point, the custom-template is applied and it's showing just fine.

    A few days later, I made another custom-template for a new page which I'm planning to make. but when I arrived at the 'Edit Page' window, I couldn't find the page-template option in the 'page attributes' tab!

    I checked the page with custom-template which I made a few days ago (the one mentioned in the first paragraph), and it's still working fine. But now I no longer could change my page template since the option is gone...

    can anyone help me to solve this problem?

  2. technodude95
    Member
    Posted 2 years ago #

    Make sure that there is a distinct header text at the top of the template. If the template .php file is in the theme and shows up on the right when you go to the editor, make sure the following code is at the top of the template or you won't be able to select it when creating a page:

    <?php
    /*
    Template Name: NAME OF NEW TEMPLATE
    */
    ?>

    You need to change "NAME OF NEW TEMPLATE" to something you can identify the template with. When you update it, it should show up as a template option when you are editing the page.

    Note:
    If you have multiple templates for different pages, make sure the above code gives a different 'Template Name:' for each template.
    I.E.:
    First custom-template would look like this:

    <?php
    /*
    Template Name: About Page
    */
    ?>

    Second custom-template would look like this:

    <?php
    /*
    Template Name: Contact Page
    */
    ?>
  3. razgrizofender
    Member
    Posted 2 years ago #

    I've done that. But it doesn't solve my problem.

    A friend of mine told me to switch my blog's template (to other than the one I'm using), and then switch it back. And viola! the page-template option appeared again! it's actually solved just like that.

    I'm not sure what's actually causing the problem though... maybe it's some kind of bug?

    anyway... thanks for answering, sir... :D

  4. Kargz
    Member
    Posted 2 years ago #

    I am using the latest 2010 theme for my site. Last 2 days images not loading properly. Seem to freeze and when updating from plugin the whole site crashes and have to log in. Could some one offer any help?

Topic Closed

This topic has been closed to new replies.

About this Topic