WordPress.org

Ready to get started?Download WordPress

Forums

[closed] My page permalinks is index.php/contact ? (19 posts)

  1. tobbs
    Member
    Posted 2 years ago #

    Hello...
    My permalinks been this
    /index.php/contact/
    /index.php/case/123

    When i remove index.php from:
    /index.php/%postname%/
    I get this error code

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
  2. RichardWPG
    Member
    Posted 2 years ago #

  3. Johnb81
    Member
    Posted 2 years ago #

    HI Tobbs,

    Just for SEO purposes it would be better to remove index.php as it does not make any sense having it in the URL.

  4. tobbs
    Member
    Posted 2 years ago #

    Thanks for re...
    But i cant remove the index.php thats the problem

  5. NuBlue-Hosting
    Member
    Posted 2 years ago #

    Hi Tobbs,

    Please can you post the contents of your .htaccess file (from the root of your webspace) so I can see what you have?

    Thanks

  6. tobbs
    Member
    Posted 2 years ago #

    Hmm... i dont have any htaccess files there... I dont fint them. In the root is nothing

  7. praveen68
    Member
    Posted 2 years ago #

    The .htaccess file is causing error. If you had changed the permalink to /index.php/%postname%/ it will give error. Since you can't find the .htaccess file make a new file .htaccess
    with

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    and upload it to root.

    Check this out.

  8. tobbs
    Member
    Posted 2 years ago #

    Thanks but i have test to do own .htaccess now and its still not works.
    i get:

    404 - File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.
  9. praveen68
    Member
    Posted 2 years ago #

    If you had altered the permalink custom value, change it back to earlier value and see.

  10. tobbs
    Member
    Posted 2 years ago #

    I have change back it.
    Everything works but i canĀ“t remove http://www.mypage.com/index.php/contact or http://www.mypage.com/index.php/blogg

  11. esmi
    Forum Moderator
    Posted 2 years ago #

    What sort of server is your site hosted on - Windows or Linux?

  12. praveen68
    Member
    Posted 2 years ago #

    Thrash those pages from Dashboard > All Pages. logout and relogin.
    Also check CHMOD permissions. Check with your service provider if the permissions for all files are 644. You can also change to 644.

  13. tobbs
    Member
    Posted 2 years ago #

    Its on a Windows 2008 server...
    Can i do somthing with that ?

  14. NuBlue-Hosting
    Member
    Posted 2 years ago #

    Is it running Apache or ISS?

  15. tobbs
    Member
    Posted 2 years ago #

    IIS...

  16. NuBlue-Hosting
    Member
    Posted 2 years ago #

    As far as I'm aware out of the box IIS doesn't support .htaccess which means you won't be able to remove the index.php from the url. A couple of possible options to remedy could be:

    • Perhaps consider getting a linux shared hosting account to host wordpress (it shouldn't cost too much and the .htaccess will work out of the box)
    • Install http://www.isapirewrite.com/ on your IIS server (this allows IIS to read .htaccess). I've never used it but I believe this could be a solution.
    • Install Apache on your Windows Server
  17. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

  18. izi24h
    Member
    Posted 1 year ago #

    Use this .htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    and change your permalink. i'll work!

  19. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Windows servers don't recognize mod_rewrite.

    [edit] And I just noticed this is 10 months old with no more useful information so I will close it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.