WordPress.org

Ready to get started?Download WordPress

Forums

My own (gr)avatar not showing in old comments after user(name) change (1 post)

  1. Oriana
    Member
    Posted 1 year ago #

    Hi all,

    after the recent brute force attack to WP sites (which luckily didn't affect me), I changed my admin username on both my self-hosted WP blogs from the default "admin" to something else, to make it more secure. I did so by creating a new user (with administrator role) and then deleting the old admin user.

    All went well but since then my avatar has disappeared from all my OLD comments, on both my websites (see for example http://thetravelgene.com/is-venice-still-romantic/ and http://orianapagano.com/background-image-not-displaying-on-ie8).

    The avatar does appear correctly if I add a new comment though, and it's still visible on comments I made on other people's blog (meaning it is not a problem with my themes nor with gravatar.com), which makes me think the issue with old comments is related to the user(name) change.

    The email address of the new user is properly set up on gravatar.com and my old comments have been properly reassigned to the new user, together with the rest of the content, so I really can't figure out what's wrong.
    Could anyone explain why comments I posted as the old (now deleted) user are no longer showing my avatar? And do you know if there's a way to fix this?

    Thank you in advance,
    Oriana

Topic Closed

This topic has been closed to new replies.

About this Topic