WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] My navigation coding messes up in firefox. (5 posts)

  1. falseaudio
    Member
    Posted 6 years ago #

    In IE the navigation under "pages" is supposed to be the only section with the gray background and the green box at the right side when you hover over it. All the other links below it are supposed to be just black and then green when you hover. In firefox all of the navigation links are the graybackground greenbox style.

    To see what I mean, look at the navigation of my website in IE and firefox
    website: http://staticabuse.net

  2. thaKing
    Member
    Posted 6 years ago #

  3. falseaudio
    Member
    Posted 6 years ago #

    I fixed all of the negative checks and it still didn't fix :[

  4. Adam Brown
    Member
    Posted 6 years ago #

    Actually, I still see several errors. But it doesn't look to me like that's the problem.

    You need to assign a unique ID or class to the "pages" links if you want them to have different styles than the rest of the links in the sidebar. Everything in your sidebar is in .nav2. Since your stylesheet assigns those colors to every link in .nav2., that includes every link in the sidebar.

    So add a unique id or class to the pages links, then modify your stylesheet with the new class name or ID.

  5. falseaudio
    Member
    Posted 6 years ago #

    AHA! Thanks!
    Worked like a charm :]

Topic Closed

This topic has been closed to new replies.

About this Topic