WordPress.org

Ready to get started?Download WordPress

Forums

My internal landing pages are blank all of a sudden (15 posts)

  1. ryantrosen
    Member
    Posted 7 months ago #

    All of a sudden my internal landing pages do not show anything when you click on them. My blog is: http://www.brickandvine.com and if you click on any of the individual post/article pages they don't load even though my browser says they are 100% loaded. For example, when clicking to this page: http://brickandvine.com/2014/01/12/leathered-and-laidback/ it never loads anything.

  2. catacaustic
    Member
    Posted 7 months ago #

    It does load something. There's at least part of the <heaader> that's loaed because you can see the pages title in the browser. If you look at the source code you'll see that it gets down into the CSS and JS links, and just stops. There's a few possibilities for this, but I'd start off with setting this in your wp-config.php file:

    define('WP_DEBUG', true);

    That should show you what the actual error is and give you a starting point of where to look for it.

  3. ryantrosen
    Member
    Posted 7 months ago #

    Sorry just getting started at all of this... I can't find my wp-config.php file. I have my wp-content, wp-admin, etc. but I can't find the config.

    In reading it seems that maybe the wp-config. file isn't uploaded... where would I get it from?

  4. catacaustic
    Member
    Posted 7 months ago #

    There are folders called wp-admin and wp-content, but wp-config.php is a file. That can make a big difference in the way that the files are dipslayed to you, so I'd check again.

    If you don't have a wp-config.php file your system would go into installation mode until it's created. There is a file in the downloaded ZIP file that's wp-config.sample.php that gets copied over when you crete the wp-config.php file automatically, so that might also explain why it's not where you're looking.

  5. ryantrosen
    Member
    Posted 7 months ago #

    I found it! So I just dropped this: define('WP_DEBUG', true); at the end of the code but nothing seems to have happened. Did I do it wrong?

  6. catacaustic
    Member
    Posted 7 months ago #

    Not at the end of the file. It's already in there before that, but it's set to false, not true. You need to change that line. The reason that it doesn't work the way that you've done it is that once a constant value is defined using define() the value can't be changed later on. So, it it's set as false originally you can't go back and change it to true later on.

  7. ryantrosen
    Member
    Posted 7 months ago #

    Okay got it... Now when I open my site it says:

    Notice: Undefined offset: 1 in /home1/brickan3/public_html/wp-content/plugins/follow/follow.php on line 3873

    Notice: Constant WP_DEBUG already defined in /home1/brickan3/public_html/wp-config.php on line 92

  8. catacaustic
    Member
    Posted 7 months ago #

    OK. That means that you haven't taken out your second define() statement in your wp-config.php file for a start. That's the first thing to do.

    The second one now is to use FTP to get into the servers file system and either delete or rename the folder for the plugin called 'follow'. That's the one that's causing the problems. If you can, I'd also report that issue to the plugins developer so that they can have a chance to fix it.

  9. ryantrosen
    Member
    Posted 7 months ago #

    Does it make a difference what I rename it? If I uninstall the plugin (since it's not very effective) will it fix the problem?

  10. ryantrosen
    Member
    Posted 7 months ago #

    Okay so I uninstalled it since I don't really need it and now when I click on a subpage it says:

    Notice: Undefined index: kill_sticky in /home1/brickan3/public_html/wp-content/plugins/google-adsense-lite/providers.php on line 506

    Fatal error: Call to a member function get() on a non-object in /home1/brickan3/public_html/wp-content/plugins/google-adsense-lite/providers.php on line 506

  11. catacaustic
    Member
    Posted 7 months ago #

    Again... Look at the plugin name, and you'll see that's causing an error.

    BUT... That error may not be fatal, and it may work without that happening. As the first one is a Notice it's OK, but as the second one is fatal, that's a no-go, so that plugin needs to go as well.

  12. ryantrosen
    Member
    Posted 7 months ago #

    Awesome! It worked! Thank you so much for all of your help! I'm new at this and learning more everyday. Thank you again!

  13. zedna
    Member
    Posted 7 months ago #

    I still don´t know how to fix this, can you please share your experience?

  14. catacaustic
    Member
    Posted 7 months ago #

    @zedna - Without knowing what your problem is it's impossible to say. Even if your problem is similar to the original problem, there's most likely a lot of other factors that we don't know about to be able to help you. Because of this the forum guidelines say that you should start your own topic rather then getting lost in existing topics like this.

  15. zedna
    Member
    Posted 7 months ago #

    I´m sorry, my problem was the same like original. But i found the solution by Clean database button(removing all plugin setting) and re-set up. Now it´s working.

Reply

You must log in to post.

About this Topic